Issues are very similar to this and this . Note that is an external GPU setup , not a discreet laptop GPU.

I can start the laptop with the card connected and it immediately outputs through the card, it works fine doing desktop/web browsing activities. The problem is whenever I attempt to run any games the output signal appears to disappear without any sort of error indication leaving me with the 'No signal' prompt.

Works on menus and load pages, and crashes only after the loading is done

Tried low-spec Halo , and ran for ~ 1min before crashing.

Alt+F4 won't work - it's like someone pulled the graphics card out , and I must press power button to shut down.

Managed to get the display to work for a few minutes and saw : " Problem Ejecting NVIDIA GeForce GTX 750 " (Image Link)

The GPU was somehow disconnected as soon as the games loaded .Of course, cables are secure.


  • Panasonic Toughbook CF-53 laptop (specifically, CF-53SAPZYC7) with Win 7 Pro SP1 64-bit (latest updates)
  • i5-3340M CPU, 8 GB DDR3 RAM
  • EXP GDC Beast v8 Mini PCI-E , GTX 750 ZT-70704-10M
  • PSU : Generic 300W Grey Box from an old yellow-white Dell office pre-built. Picked from a PC fitted with a Celeron SL6RP .

PSU is sketchy, but as GPU is rated 55 W only, it may not be that ?

And, a quick Google search of "problem ejecting NVIDIA GeForce GTX 750" returns many forum posts on Nvidia's website that point to driver instability 3 to 5 years ago.

What is the likely cause and any ideas what can solve this ?


2 Answers 2


Bit of guesswork here but there were multiple possible problems.

Firstly, the original PSU is incredibly old - while the 'core' ATX standard hasn't changed all that much in the near 2 decades since your CPU was made - the demand on various rails has varied, with increased load and requirements on the 12v rail.

Its also right smack in the middle of the capacitor plague - so the reliability of the machine as a whole are suspect.

Finally all your load is on the 12v rail(s) so its possible while the overall capacity of the power supply was sufficient, it might not have been providing enough power at load to power the GPU. While it "worked" it probably didn't have issues at the "base" power usage, and glitched out at higher wattages.

Fundamentally, you were not getting the 75w you needed for the slot to meet the PCIe spec via the 12 v rail. That it was glitching at much less demanding loads was not good.

Generally I'd not skimp too much on a PSU - at the very least, if buying cheap, get new, or at least be aware that in many builds, its a part that fails, protecting the rest of the system, and is meant to be fairly easily replaced with minimal fuss.

  • *55W , you mean ?
    – An Ant
    Dec 6, 2020 at 12:05
  • Your PCIe slot is supposed to supply up to 75w - as per spec. That your PSU couldn't even do 55w is the source of your problem, but the PSU you use should be meeting the minimum spec, even if your video card isn't that power-hungry
    – Journeyman Geek
    Dec 6, 2020 at 12:08
  • Ah I see. Clears it up.
    – An Ant
    Dec 7, 2020 at 3:38

Fixed by replacing old , sketchy PSU to new, cheap ~$8 PSU.

From discussion on other sites and forums , I think the issue was inability to hold consistent current and/or voltage and/or power at load.

Thanks to @JourneymanGeek 's comment for suggesting this.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .