1

enter image description here

I'm not able to start the virtualbox when I try to open the virtalbox I got this Error message I need help on this

7
  • 1
    Is the client machine a 64-bit machine? And is Hardware Virtualization set ON in the BIOS?
    – John
    Dec 5 '20 at 14:09
  • 1
    Enable SIP. If that doesn’t work you will have to give us more details
    – Ramhound
    Dec 5 '20 at 14:11
  • Yes it is 64 bit Dec 5 '20 at 14:20
  • Let me check once again in the BIOS. I already turn on the virtualization. anyways i'm gonna check again Dec 5 '20 at 14:22
  • I checked Vitrualization tech is enable Dec 5 '20 at 14:35
0

The article Fedora virtualbox RC: NS_ERROR_FACTORY_NOT_REGISTERED advises the following actions:

yum  install  dkms
find /usr/lib/virtualbox -maxdepth 1 -name '*.so' -exec ln -s {} /usr/lib/virtualbox/components/
chown root.root /tmp
chmod ug-s /tmp
chmod 1777 /tmp

A very similar bug-report, although old one, is OSE / Hardened: NS_ERROR_FACTORY_NOT_REGISTERED => Fix symlinks.

The solution here is to add the following symlinks:

cd /usr/lib64/virtualbox/component
ln -s ../VBoxDDU.so .
ln -s ../VBoxREM.so .
ln -s ../VBoxRT.so .
ln -s ../VBoxVMM.so .
ln -s ../VBoxXPCOM.so .

Then restart VirtualBox.

If I understood right the comments, the problem arises when the bin/ directory was moved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.