0

As the title suggests, I tried remapping Caps Lock to Control on a Kinesis Advantage (this is after first enabling "Mac mode" for the middle keys).

Instead, I find that it is remapped to Command instead.

How I confirmed: initially by observing what was happening when I used key combinations, but then by activating the OS X Keyboard Viewer, and seeing that the Command key was flashing when I pressed the Caps Lock key.

Things I've tried: (1) resetting the remapping and retrying, (2) mapping a different key (Home) and observing that now it was mapped to Command instead (!)

This is a bit of bummer, since while the keyboard as such is fantastic, the default placement of Control isn't great for me (crimping my Emacs style a lot ATM 😁)

Much thanks in advance!

1
  • Not a solution but a workaround: I remapped the key "in software" via System Preferences. Of course that meant the annoying Caps Lock sound was still present, but I was able to fix that by Progm + Shift + F8.
    – agam
    Dec 12 '20 at 0:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.