7

I have a pair of Bluetooth headphones that I've successfully paired with my Windows 7 64 bit machine and audio plays through them without a hitch. On the Device Stage under the properties of the headphones in troubleshooting it shows "last connected" as "currently connected" even if I power cycle the headphones or after a reboot of my computer. So the Windows Bluetooth stack has no trouble finding them.

The problem I have is that whenever the headphones reconnect to my pc they show up as disconnected in the Sound Settings and no sound is routed to them until I manually connect them. I have to go into Sound Settings, then from the Playback tab right click on the headphones and choose the Connect option.

Is there a way to make the Sound Settings connect automatically whenever the headphones are available to Windows?

3

If you right click your volume/speaker icon by the clock and go to Playback Devices you could try setting them as the default playback device. That way, they should take over when they reconnect.

I'll admit, even with Windows 7 I find the connect/reconnect situation doesn't exactly go smoothly at all times. I liken it to docking/undocking your laptop. Most of the time it's pretty smooth. Occasionally not so much.

| improve this answer | |
  • This is the best solution I've found thus far but it's by no means ideal. There's still a delay as to when the headphones decide they want to connect however. – MyItchyChin Feb 3 '11 at 15:23
  • I feel like that delay is pretty standard with bluetooth. My bluetooth mouse and keyboard both have a delay in activation after my computer has been off/untouched for a while. – manyxcxi Feb 3 '11 at 17:16
2

I've got a Logitech Bluetooth device, and I use a small quick-and-dirty AutoHotkey script to connect or disconnect. And I love it.

Save it as connect.ahk and adapt it to your needs. Look at the AutoHotkey documentation on how to do it. Since I've got a Lenovo Thinkpad I do not know if it works with your PC, but perhaps it may give you another idea how to solve it. Good luck!

;FHEM: Turn on Receiver Power Socket (You probably want to delete the following line!!)
;runWait, "curl.exe" "http://fhem.box:8083/fhem?cmd=set`%20music`%20on"

;Open control panel's BT device connect Window (Adapt the Address to your device specific one)
run, "C:\Program Files\ThinkPad\Bluetooth Software\BTWUIExt.exe"  /deviceAddr=c8844711xxxx

;*******************
;replace "(49)Logitech Adapter" in all following lines by the Window title depending on your device
;*******************
; Wait for the Window
WinWait, (49)Logitech Adapter,
IfWinNotActive, (49)Logitech Adapter, , WinActivate, (49)Logitech Adapter,
WinWaitActive, (49)Logitech Adapter,

;then click on "connect"/"disconnect" button (the window must be big enough to show the button), maybe you need to adapt the coordinates (?)
MouseClick, left,  778,  213
Sleep, 100

;close window
WinWait, (49)Logitech Adapter,
IfWinNotActive, (49)Logitech Adapter, , WinActivate, (49)Logitech Adapter,
WinWaitActive, (49)Logitech Adapter,
Sleep, 100
Send, {ALTDOWN}{F4}{ALTUP}
| improve this answer | |
0

My headset gets automatically connected after turning on as long as I keep the "Bluetooth Device Control" window open. To get to that window: right click on the bluetooth icon in the tray -> Show Bluetooth Devices -> right click on your device -> Control.

| improve this answer | |
0

After your device is paired, go to: Devices and Printers → Select your Bluetooth Speaker/Headphone's name → Create a shortcut on to Desktop → Open Start Menu → All Programs → Startup → Add the BT Speaker/headphones shortcut into that folder → Restart the computer

Now it should automatically open that device window at login and automatically reconnect it

I tested this on Windows 7 64-bit

| improve this answer | |
  • On SU we expect high quality answers (not that your method doesn't work) but we expect everything to be spelled correctly and thoroughly detailed. Your steps lack much explanation; some may get what you are trying to say but not normal browsers. Please edit your post. – El8dN8 Aug 30 '17 at 11:10
0

There is a problem with setting your Bluetooth (BT) speaker as "default sound output" if you're using a USB Bluetooth adapter.

In this case, if you start your PC with your BT speaker powered off, the default device automatically changes back to the system default (not the BT speaker), so you have to 1.) power on your BT speaker; 2.) set the BT speaker as the default device manually; and you have repeat it every time.

I found a solution for this problem. This is a batch file that must be started with Windows (I tested it under Windows 7 and Windows 10). It is constantly trying to set your BT speaker as the default device, and as you turn on your speaker, it stops monitoring and closes itself. It's working with a 3 second pause between checks so it is not slowing down your system noticeably.

First, you have to create a folder and download two freeware utilities into it:

1.: SoundVolumeView by NirSoft: http://www.nirsoft.net/utils/sound_volume_view.html

2.: NirCmd by NirSoft: http://www.nirsoft.net/utils/nircmd.html

You need to power on your BT speaker and set it as the default sound output. (Follow john's answer here to get it done.)

Now you have to export your current sound device settings by using this command:

SoundVolumeView.exe /scomma AudioDevices.txt

A text file named AudioDevices.txt is created. Open this file, and search for your BT speaker in its content. Copy that line to the clipboard from its beginning to the ",Render" part. For me, this specific part was this (but it is different for everyone!):

Headphones,Device,Render,Anker SoundCore stereo,Render

Now create a file named set_default_device_cycle.cmd with this content:

@echo off
timeout /t 10
:start
NirCmd setdefaultsounddevice "Headphones" 1
SoundVolumeView /scomma "%temp%\AudioDevices.txt"
>nul find "Headphones,Device,Render,Anker SoundCore stereo,Render" "%temp%\AudioDevices.txt" && (goto end)
cls
echo Waiting for the Bluetooth Speaker to be powered on...
timeout /t 3
goto start
:end

Look at the line that begins with ">nul find". You have to swap the quoted part with the text that you've extracted from your AudioDevices.txt file. Do NOT use the text I've provided as it only works in my environment, 99% chance that your will be different. And check the line starting with "NirCmd setdefaultsounddevice", the text in the quotes (for me it was Headphones) has to be equal with the beginning word of the text that you've extracted from AudioDevices.txt.

Save this file (set_default_device_cycle.cmd) and place it in your Startup folder to make it run every time you load Windows. That's even better to put a shortcut to it in the Startup folder, and in the shortcut's properties set "Run" to "Minimized" to hide it's black window.

| improve this answer | |
0

This was an easy fix for me. I have two bluetooth headsets (Jabra Evolve 65 and Beats Studio 2) that I use for both work and leisure i.e. music, phone calls, games etc. After first solving an issue where the devices would pair but not show up as a playback device, I was then able to solve the issue of having either of these headsets auto-connect once turned on.

The following steps are what I took in order to have my headsets auto-connect:

  1. Ensure that your bluetooth headset can successfully pair and connect to your system as a playback/recording device
  2. Double click the Bluetooth icon in your task bar to bring up the window with your bluetooth devices. You should see your paired headset here.
  3. Right-click over your headset and select "Properties"
  4. Select "Services" tab and in the list of Bluetooth Services, uncheck everything except "Handsfree Telephony". This should now auto-connect your bluetooth headset
  5. If desired, open up your sound settings and set your headset as default playback and recording device.

I found that "Handsfree Telephony" was the only service that would allow my devices to auto-connect. All other options tested both in isolation and combined with Handsfree Telephony did not work for me.

Hopefully the steps above manages to save a lot of you some headaches!

| improve this answer | |
-1

Solved (at least if you have Realtek HD Audio):

  1. Click to show all icons in the system tray,
  2. Right click on the small brownish coloured speaker (this is Realtek)
  3. Select "audio devices"
  4. Than you should see a list of your devices (make sure your Bluetooth device is on)
  5. Right click and select (set as default device).

Now your device will automatically connect when switched on!

Sorry I can't post photos. But so you know, if you have Realtek it superseeds the Windows audio manager, if default device is set on Windows Realtek will still override that.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.