I've trying to do this for a while and it just doesn't want to work. It installs the plugin, it shows the plugin, but upon opening a new Vim instance it just doesn't load the plugin. I think it might be something to do with macOS (I'm using Catalina) but I'm pretty sure that's not the case.

Here are the screenshots of the installed plugin:

And there is the picture of a new Vim instance with a non working plugin:

1 Answer 1


Ok, seems like I wasn't careful enough. If using zsh shell you need to add these to both your .zshrc and .vimrc files

Add this to your .zshrc file:

export TERM=xterm-256color

And these 2 to your .vimrc file:

set laststatus=2
if !has('gui_running')
  set t_Co=256
  • It's never a good idea to set your TERM variable unconditionally in your zshrc file. Check your terminal emulator's settings to see if you can tell it to report its TERM as xterm-256color instead. Also, t_Co should automatically get set to 256 by Vim if your TERM variable supports it.
    – Heptite
    Dec 18, 2020 at 3:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .