0

Whenever i try to suspend my laptop (Lenovo Y530 with hybrid graphics (Intel & NVIDIA 1050Ti)) i face this issue:

nvidia-modeset: ERROR: GPU:0: Display engine push buffer channel allocation failed: 0x65 (Call timed out [NV_ERR_TIMEOUT])
nvidia-modeset: ERROR: GPU:0: Failed to allocate display engine core DMA push buffer
kernel: BUG: unable to handle kernel NULL pointer dereference at 0000000000000070
kernel: IP: [<ffffffffc20619ae>] _nv002366kms+0x5e/0x100 [nvidia_modeset]

I tried both the solutions in this link but to no avail. i tried to identify if it is a distro, kernel or even a specific device issue thing. but it turns out it is only but only a nvidia problem.

I am using nvidia-driver-455; i went to nvidia xserver settings and changed the graphics card from nvidia to intel and rebooted and tried suspending and it worked without a single issue.

unfortunately i cannot suspend my device under any circumstances as long as i am using nvidia.

I tried to use nouvea but -for some reasons- it does not work perfectly on my device (it specifically does not refresh the screen at all, just a picture displayed).

5
  • Try updating BIOS, Chipset (video needs Chipset) and Video drivers with the Lenovo System Update app. Restart and test. – John Dec 13 '20 at 14:45
  • please, can you give instructions to that? – Omar Shawky Dec 13 '20 at 15:42
  • @John i used this link (support.lenovo.com/eg/en/downloads/…) but to no avail – Omar Shawky Dec 13 '20 at 16:16
  • You may need to stick with Intel Graphics. I do not know how well your laptop supports Linux. – John Dec 13 '20 at 16:33
  • @john i know NVIDIA and Linux do no go a long but is there really a "linux compatability" that differs from laptop to another? – Omar Shawky Dec 13 '20 at 17:11
1

Switching from 460 to 450 nvidia driver works for me on Ubuntu 20.10, GeForce GTX 1050 Mobile, Unity gui.

0

I used the NVIDIA Driver Downloads page to search for Linux drivers for the NVIDIA 1050Ti.

This gave me the Linux x64 (AMD64/EM64T) Display Driver for 64-bit computers.

If installing this driver fixes the problem, all is good. However, ensure that you can go back to the previous driver in case it doesn't work on your computer.

2
  • i download it using software & updates (software-properties-gtk) are they the same? – Omar Shawky Dec 13 '20 at 17:55
  • No, the driver in the repository is often behind the one from the manufacturer. However, if it works fine then no reason not to keep it. – harrymc Dec 13 '20 at 17:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.