0

Since recently, Firefox (now on 78.4.1esr on Debian stable) is showing me a top-option to enter Google when typing things in the address bar.

Needless to say, Google is not my default search engine, nor is it a frequently used page. What's worse, it often enters Google search if I press some wrong keys, instead of opening the page I enter in the address bar. about:config does not reveal anything.

How is this possible, and how can I completely de-googlify my browser?

Is this an official policy of Firefox? Looks like a very bad choice to me.


Removing Google as one of my eight search engines "fixes" the issue. But ideally I would like to keep it around for when I need it. Is Google perhaps gaming the algorithm that determines what is shown in the most frequent pages when the context menu pops up?

enter image description here

2 Answers 2

0

There is a blog that helps remove Google from Firefox, although some things seem a bit outdated with the current UI.

The crucial setting seems to be keyword.enabled that can be found in about:config, and turned off (false). In any case, removing Google as a search provider also fixes this, although at times your other search providers (e.g. Qwant, Duck Duck Go) may appear when typing "keywords" in the address bar, unless that setting is set to false.

0

This might fix it:

  • Click the three-bars menu and select "Options"
  • Go to the "Privacy & Security" section
  • Under "Address Bar", uncheck "Top sites" (and any other option you don't like)
  • Restarting Firefox might be required.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy