0

I have created a SMB share on a small debian server. I can connect to it via a notebook(with debian), a notebook (with Win10 Pro) and i also tested it with a app on my smartphone. Everything works fine. Just my pc (Win10 Edu) cant find the SMB share. A virtual machine running on the pc also can't find the SMB-share. Net view returns code 53. I have tried multiple things if read in forums, but nothing helped so far. Hope you can help me!

EDIT1

The output of testparm -s -v | grep protocol is:

client ipc max protocol = default
client ipc min protocol = default
client max protocol = default
client min protocol = CORE
server max protocol = SMB3
server min protocol = SMB2

i set in the smb.conf in the [global part]:

max protocol: SMB3 
min protocol: SMB2

EDIT2

I just tried it with three additional computers:

Two with Win10 Edu -> Can't find/access SMB-share

One with Win10 Pro -> Works fine So i guess it must be some kind of problem with the Win10 EDU-Version.

EDIT3

I tried gpedit.msc:

Computer Configuration\Administrative Templates\Network\LanmanWorkstation
and set insecure guest logon to enable.

Restarted the computer

-> Also doesn't work

then i uncommented the line in /etc/samba/smb.conf

#map to guest = Bad User

-> Connection WORKED!!

Nextstep:

Activate map to guest = Bad User Check GPEDIT -> insecure guest logon STILL ENABLED

-> Connection doesn't work

So checking regedit: Windows Regsitry:

HKEY_LOCAL_MACHINE -> SYSTEM -> CurrentControlSet -> Services -> LanmanWorkstation -> Parameters

AllowInsecureGuestAuth set it to 1

Restarted the computer -> Connection WORKED!!

So i guess the problem is solved :) Hope this Thread may help other users! Find the solution on

Windows 10 and Server 2016 clients block access to (Samba) shares with public guest account: Technical analysis and workaround for event 31017

2
  • What version of SMB is the share configured to use? Edit your question instead of submitting a comment
    – Ramhound
    Dec 16, 2020 at 11:30
  • Does this help or this
    – Ramhound
    Dec 16, 2020 at 12:03

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy