0

we have a set up with almost 100 devices, it used to work fine some months ago when we had fewer, but now our main router constantly crashes because it just can't handle so much.

We had 8 routers set as access points and one main router as DHCP server, this set up doesn't work anymore, as such we decided to set another router as DHPC server in an specific section of the building, connected through the WAN port to the first router, and everything is working far better than ever.

Now, to do this we kept the main router network as 192.168.0.1 and we set the second one as 192.168.1.1, however, with this configuration devices can't interact with each other if they are in different networks. We need all devices to be able to interact with each other regardless of which network they are in.

We plan on setting more routers as DHCP servers for each section of our business as it really seems to improve stability and speed.

6
  • 1
    Define "interact". What do those devices require – just ordinary TCP/IP connections? do they rely on broadcast IP packets for discovery? do they need multicast IP? or do they even use some non-IP protocol? – user1686 Dec 16 '20 at 19:00
  • Being able to fully use shared folders through windows explorer – Logista Dec 16 '20 at 23:10
  • Do you need the ability to list (discover) all the computers, or is it enough to directly access specific shared folders through a shortcut (\\somepc\folder)? – user1686 Dec 16 '20 at 23:46
  • Any of the two will do – Logista Dec 17 '20 at 2:33
  • see if it's helpful to you: superuser.com/questions/131227/… – Gloria Gu Dec 17 '20 at 9:17
1

You just need to tell your systems that the network is 192.168.0.0/16. On Linux, eg.:

route add -net 192.168.0.0 netmask 255.255.0.0 dev eth0
7
  • According to OP's description, the two subnets are physically separate due to the way they re-connected the second router – they're not just two addreso ss ranges on the same broadcast domain anymore, so there's no use in telling the OS that the other network is on-link when it isn't. – user1686 Dec 16 '20 at 19:10
  • I didn't interpret his description as you do. – Gerard H. Pille Dec 16 '20 at 19:57
  • @user1686: The WAN connection created a physical sub-segment to the main router. The problem is just that there is no route between 192.168.0.x and 192.168.1.x. I would have answered the same. +1 – harrymc Dec 16 '20 at 20:53
  • @harrymc: While it is true that a route is missing, the route also needs to be correct – an on-link route makes no sense precisely because it's a separate "sub-segment" as you say; it needs to have a gateway specified. – user1686 Dec 16 '20 at 21:02
  • @user1686: I would understand your comment to say that with on-link (directly accessible), all the 100+ computers would be on the same network and will all get all packets, which might cause congestion. Yes, when the poster expands to that stage, he will need to segment and use gateways, which will complicate his network administration. The price of success. – harrymc Dec 16 '20 at 21:21
0

I managed to do what I wanted, it was quite easy and still works with Windows 10

https://www.npcglib.org/~stathis/blog/2013/02/18/windows-task-sharing-files-across-different-subnets/

1
  • Is this the answer to your question? – RomanK Dec 17 '20 at 13:39
0

Make sure the 2nd router does not have NAT enabled.
Then configure the gateway router to NAT for both networks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.