3

There are many mentions of this folder on the web, it's clear that it relates to Windows 10 telemetry, and many people want to get rid of this folder (it's 30 GB on my C: drive at the moment, and it accounts for most of the mysterious loss of free space over time). However, all the solutions I could find are outdated as they suggest disabling the DiagTrack service which no longer exists.

I'm running Win 10 Pro x64 2004. How can I at least delete this folder (inaccessible to regular file managers), and preferably - stop it from being regenerated?

P. S. I was able (to my surprise) to simply delete this folder with rmdir /S from Administrator command prompt, but the real question is how to stop it from regenerating.

1
  • 1
    (1) In which subfolder are the files inside C:\ProgramData\Microsoft\Diagnosis\ETLLogs? (2) Could you post online one example .etl file? (3) Run EventLogChannelsView and see if you can find C:\ProgramData under "Full Path" (sort by click on column), and if it's there then right-click it and select Disable. – harrymc Apr 11 at 10:29
1
+50

It seems that in your case Windows Telemetry is running wild. The following is a list of all the methods I know to stop telemetry. Reboot after applying.

Change Privacy Settings

  • Open Settings > Privacy > General
  • Toggle all options to Off
  • Select on the left "Diagnostic and Feedback"
  • Select on top the option saying "Required diagnostic data"
  • Toggle "Tailored experience" to Off

Disable Microsoft Compatibility Telemetry

Run Command Prompt (CMD) as Administrator and enter the following commands:

sc stop DiagTrack
sc config DiagTrack start= disabled
sc stop dmwappushservice
sc config dmwappushservice start= disabled
echo "" > C:\\ProgramData\\Microsoft\\Diagnosis\\ETLLogs\\AutoLogger\\AutoLogger-Diagtrack-Listener.etl
reg add "HKLM\\SOFTWARE\\Policies\\Microsoft\\Windows\\DataCollection" /v AllowTelemetry /t REG_DWORD /d 0 /f

Disable From The Local Policy Editor

  • Run the Local Policy Editor (gpedit.msc)
  • Navigate to the following location:
    Computer Configuration > Administrative Templates > Windows Components > Data Collection and Preview Builds
  • Locate and double-click on the "Allow telemetry" option
  • Change its status to Disabled
  • Click on OK to save the changes

Use Task Scheduler to disable CompatTelRunner.exe process

  • Run Task Scheduler
  • Expand the following folders: Task Scheduler Library > Microsoft > Windows > Application Experience
  • Right-click "Microsoft Compatibility Appraiser" and select "Disable"
  • Confirm to complete the process
2
  • You could be right, I did run one or two telemetry blocking scripts from Github. I would never have thought they'd go as far as to completely delete service, I agree it's too much. And thank you for pointing me to the Repair Install option, I've never done that before and would like to try it because I have a very annoying problem with this system: an update fails to install and it gives me grief regularly. – Violet Giraffe Apr 13 at 11:43
  • Answers to my comment below your post may help to better define the problem. – harrymc Apr 13 at 20:09
1

This folder is filled by Microsoft Compatibility Telemetry (CompatTelRunner.exe), it is started by a scheduled task, the task is located at \Microsoft\Windows\Application Experience\ and its name is "Microsoft Compatibility Appraiser", however there are three other tasks there, so you might disable them all.

This is a PowerShell one-liner that does the job, note you need Administrator Privileges to do so.

"Microsoft Compatibility Appraiser","PcaPatchDbTask","ProgramDataUpdater","StartupAppTask" | %{ Disable-ScheduledTask -TaskPath "\Microsoft\Windows\Application Experience\" -TaskName $_ | Out-Null }

If these commands give you errors, then you need run these commands with TrustedInstaller privileges, you can use either NSudo or PsExec.

1
  • 2
    In addition to this answer, if you have another (non-ssd) drive attached, you can junction a folder from it to the SSD drive and save the wear and tear on your SSD drive. – Señor CMasMas Apr 11 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.