1

How do I format a microsd card that is not recognized by any computer ... Windows or Linux?

I don't think its bad because it was working then I tried to create an ubuntu remix bootup drive which I had done before and there was an option to format the drive. Which I mistakenly did so I think it might be in some strange format. Don't think the writes are used up yet bc I barely used it

2
  • Is the computer you're trying to use it on the same computer as you formatted it on? Jul 8, 2010 at 5:41
  • Yes, I first tried it on the same computer (Acer Aspire One with Ubuntu Remix) then I also tried it on a couple other computers but I was not able to try it on Windows. Jul 8, 2010 at 15:16

5 Answers 5

2

It's very possible that the card is trashed by Electro-Static Discharge damage. I expect 2.7V microSDs are pretty sensitive to ESD. There is a Current Limit Error register on the host adapter which could tell you if the host adapter has detected a short but I don't know how you'd access it.

2

Are you sure about it not being recognized by Linux? What does the syslog say while inserting the card?

Start your favourite terminal, login as root (using su) and run this command (or prepend it with sudo):

tail -f /var/log/messages

This continuously displays new lines of syslog.

Then insert the card into the reader and watch for any useful information ie. error messages, assigned device name, etc.

0

If it's not recognized at all it may be bad, but traditionally they are formatted to FAT or FAT32

0

Try to run gparted and see if the card crops up in there, and then format it. (upper right dropdown box for your drives). Gparted should be available in the ubuntu repos.

Also check out /dev for something like sdx (depending on your setup, x might be b, c, d, e, etc...) usually, sda is your main drive, and sdb will be any removable media, but beware, as YMMV. If you unplug the card, you should see the appropriate entry in /dev disappear, and if you plug it back in, you should see the entry reappear.

Let us know if it comes up in /dev

-1

Had the same problem here. Worked this out by using my camera to format the SD card. After that Ubuntu was able to read the SD card again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.