0

Netdata has been installed on docker container. I tied to add new docker container into netdata.cloud as below; I tried to run below command in host docker server

docker exec -it php7.4-apache2 netdata-claim.sh -token=token -rooms=my_room2 -url=https://app.netdata.cloud
docker exec -it php7.4-apache2 /usr/sbin/netdata-claim.sh -token=token -rooms=my_room2 -url=https://app.netdata.cloud

I tried to run below command in php7.4-apache2 container

sudo netdata-claim.sh -token= -rooms=my_room2 -url=https://app.netdata.cloud

But end up with

OCI runtime exec failed: exec failed: container_linux.go:370: starting container process caused: exec: "netdata-claim.sh": executable file not found in $PATH: unknown

I would like some suggestions from expertise.

2 Answers 2

0

Try providing relative paths (and not only filenames) when executing sh-files by adding ./, for example:

sudo ./netdata-claim.sh <...>

3
  • Hi anion, Thanks for your reply. Where do I have to run ur command, either host linux or, netdata docker or php7.4-apache2 docker?
    – Ryan Exlay
    Dec 24, 2020 at 13:00
  • you must simply add ./ in the command you have just executed, shown in your second listing in your question.
    – anion
    Dec 24, 2020 at 13:03
  • ` bash: ./netdata-claim.sh: No such file or directory ` Same error. I am sorry, if my question may confuse you. I may not get the concept how does netdata work. First, I installed netdata on docker container. Then I want to monitor another container. They are on the same host but different containers. first commands are run on the host second command is run on the different container (php7.4-apache2 container but not netdata container. Can I monitor php7.4-apache2 container from different container where netdata installed?
    – Ryan Exlay
    Dec 24, 2020 at 13:19
0

First of all you can most certainly monitor other containers while having netdata installed as a docker container.

To claim the netdata container, you should be able to do it via running this command on the host machine:

docker exec -it netdata netdata-claim.sh -token=98FMbk9sx-22f75VU2FiC2xzoeeN8umkxDmh8zeeOKACCkevYBSCOU2B0o7g75-cUXc0QpLZ6ej-ZvSokSWelisrncFwi4RXFfpkNexBXv8UnHSDkvccjv0xjBYFPww-Vu28coQ -rooms=abb4d556-6d1f-46a1-a04d-663b86ccf4ea -url=https://app.netdata.cloud

Please note that the netdata just after -it is the name of the container that runs netdata, so in case the name of the container is a different one, you will have to change that part of the command(e.g docker exec -it <container_name> ..)

Keep us posted if you make it work!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.