I just finished backing up ~100GB to an external hard drive, during which my computer was very unresponsive even though my CPU and memory usage were very low and my operating system is installed on a separate SSD (not the one I'm copying from).

When the backup had finished I "safely removed" the external SSD, then waited for the popup to tell me I could unplug it before finally unplugging the hard drive.

Then I noticed my computer was still very unresponsive so I rebooted it and everything was back to normal, until I tried watching a YouTube video in full screen. I'm only seeing a few frames per second and system monitor shows 1 CPU core at 100% while the video is playing. It's not just YouTube either, every site is slow and unresponsive.

I should maybe also mention that before backing up to an external hard drive I had first tried to copy my files to an internal hard drive instead, but I was getting a lot of I/O errors and after a bit of fiddling trying to see if the drive was dead I ended up removing it from my system because it wasn't getting recognized at all anymore. While messing with the broken hard drive Firefox was still working fine as far as I remember.

Only Firefox is slow, other programs, even other web browsers or web based apps seem to be running fine. I did get a few dropped frames while testing full screen video in chrome but the video still looked smooth and I don't usually use chrome so I'm sure if that's normal.

I have tried:

  • reinstalling Firefox
  • using a new blank profile
  • messing with Firefox performance settings
  • updating graphics drivers
  • rebooting my computer multiple times throughout each of these changes


  • OS: Ubuntu 18.04.5 LTS x86_64
  • Kernel: 4.15.0-128-generic
  • CPU: Intel i7-8700k (12) @ 4.700GHz
  • GPU: Nvidia GeForce GTX 1080
  • Memory: 4x 8GiB @ 3200MHz

Any help is much appreciated.

EDIT: It's not just Firefox!

After some more testing it seems my GPU usage also hits 100% when doing anything in Firefox. Steam, however, is also very slow and hits 100% on my GPU when interacting with the program in any way.

Minecraft runs fine though, at a steady 130fps and 35% GPU usage.

EDIT 2: After enabling gfx.webrender.enabled Firefox runs fine again, but that's not a fix, it's a workaround. Firefox used to run fine with webrender disabled and steam still doesn't run very well unless I disable hardware acceleration, but that doesn't make any sense. What's going on here?

EDIT 3: Firefox with webrender disabled and steam with hardware acceleration enabled are very smooth on the same computer running Windows 10 instead of Ubuntu.

  • 1
    "my computer was very unresponsive even though it was using barely an system resources" -- No, your computer was unresponsive because certain system resources were being used extensively. By "system resources" you probably focus on CPU activity and memory allocation. But there are other "system resources" that are heavy used when performing file copies and disk backup: i.e. memory bandwidth and I/O bandwidth. Unless you have a special computer with dual-ported memory, only a single memory access (read or write) can be active at any moment. I/O errors will also reduce performance.
    – sawdust
    Dec 25, 2020 at 23:22
  • @sawdust My theory would've been either memory bandwidth or frequent context switches between the kernel and NTFS fuse driver. I agree my statement about barely using any system resources is incorrect so I've changed that.
    – DutChen18
    Dec 25, 2020 at 23:33

1 Answer 1


I'm not very sure about Linux, but doesn't it have an option like ReadyBoost on Windows? Uses an external drive as pagefile? I'm not sure but that maybe doing something to the system?

  • The page file is on my main SSD. I think from the high cpu and gpu usage it's clear that memory or paging isn't the issue.
    – DutChen18
    Dec 26, 2020 at 10:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .