11

POWERCFG -requests shows that System32\MoUsoCoreWorker.exe is the reason the computer never sleeps.

This article notes that restarting the Windows update service can fix it temporarily. It does clear MoUsoCoreWorker.exe from the POWERCFG -requests report. But hours later, MoUsoCoreWorker.exe is running again, and the computer still won't sleep.

Is there any better approach?

2
  • 1
    Questions: (1) This was an issue back in June 2020. Have you updated Windows to the latest version? (2) Do you perhaps have a failed update in Windows Update history? (3) Is it possible that Windows Update is configured to update your computer at night? – harrymc Dec 26 '20 at 19:02
  • The system is a new build, installed from Windows10-2004-x64.iso. I guess Windows Update literally takes several days of work by MoUsoCoreWorker to get a new system updated. After a few weeks, is now sleeping OK with no changes on my part. – tim11g Dec 31 '20 at 18:16
2

According to the information supplied by the poster, it's most likely that Windows was waking up the computer at night in order to install new updates, as are the default settings of Windows Update.

Once all updates have been installed, the computer goes back to sleeping happily and doesn't wake up any more. Until the next time.

Finer control over Windows Update is found in Settings > Update & Security > Windows Update and in Power Options > Change plan settings > Change advanced power settings, under Sleep, Allow wake timers.

1
  • 1
    That's basically the answer. Actually the computer was not "waking up at night", it was never entering sleep at all, any time of day, which got me looking at POWERCFG -requests. That went on for a few days, but eventually it settled down and is able to sleep now. – tim11g Dec 31 '20 at 22:55
1

Just run this command in an elevated command prompt:

powercfg /requestsoverride process "\Device\HarddiskVolume3\Windows\System32\MoUsoCoreWorker.exe"

Note that the part in quotes needs to match the path from powercfg -requests

2
  • This didn't help me. PC is still operating awake. :-/ – CraZ Mar 18 at 0:21
  • I just tried it, and the evil MoUsoCoreWorker.exe no longer shows up in the powercfg /requests list. I do have an "optional" update pending; which I generally put off as long as I can. – Steve Smith Mar 25 at 23:11
0

I have had this same problem on my PC on Windows 10. Could NOT figure it out and did research for hours. Pulled up command prompts and only thing it said was I needed to preform an execution for mousocore worker. Even tried an override code - nothing worked.

Finally I got the bright idea to go to task manager find MoUSO Core Worker Process (MoUsoCoreWorker.exe) running under background processes and right click to end task. Working fine now and my computer went straight to sleep after. Hope this saves some time and frustation for someone.

1
  • Yes, this helps, but after the restart (or PC resume), the process is back and you have to manually kill it again (so this is not a permanent and working solution). – CraZ Mar 18 at 0:22
0

For me the Solution was:

powercfg /requestsoverride process "MoUSO Core Worker" execution
powercfg /requestsoverride process "USO Worker" execution

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.