0

Everytime I hit Shift+Alt or Shift+Ctrl (Windows Keybinds for switching languages) it changes the input language without even notifying me.

enter image description here

1
1

You could also disable the keybinds/ keyboard shortcuts/ hotkeys.

Go to Settings > Language (tab on left) > Keyboard (one of the big buttons near the top of the page) > Input language hot keys (under Switching Input Methods). This opens the Text Services and Input Languages settings box (maybe you can search for that directly; didn't work for me). Under the Advanced Key Settings tab, click on the first listed Action, hit the Change Key Sequence button, and set it to "(None)". Do this for each listed Action and click on OK.

The keyboard shortcuts annoying you should now cease to function.

1
  • I have changed the question to match your answer. Thanks! – AzulShiva Dec 30 '20 at 17:16
0

To remove unexpected languages, you could manually delete them from win10 Setting "Edit language and keyboard settings"

1.Navigate to Preferred Language, then move the chosen language by down arrow if it is in the top of the list because the remove options is greyed out. enter image description here

2.After the remove option appeared, click remove. As a result, the relevant keyboard will be deleted as well.

enter image description here

But if this is not the case, you could check if the suggestion of modifying registry key would help. https://answers.microsoft.com/en-us/windows/forum/windows_10-start/cant-remove-a-keyboard-layout-in-windows-10/058acf33-16d9-47f4-a24b-245b8823d90e?auth=1

2
  • You can see in the screenshot provided that I have only one language in the list – AzulShiva Dec 30 '20 at 17:13
  • Then you may try the suggestion by modifying the regsitry with necessary backup before making changes. – Jenny Dec 31 '20 at 1:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.