I have a Dell XPS 8910 with a HDD that seems like it is about to fail. I have backed up all files and created a recovery USB flash drive on a 16GB flash drive.

I am trying to "Recover from a drive" in the recovery options. When I disconnect the failing HDD and install a new SSD and try the recovery process with the USB it consistently fails at around 10% on the "Just remove my files" option and at about 90% on the "Fully clean the drive" option. The specific error message is:

“There was a problem resetting your PC. No changes were made.”

I have tried two different USB flash drives and I am getting exactly the same result with each.

What troubleshooting options do I have at this point?

  • "What troubleshooting options do I have at this point?" - You should replace the drive. What you are doing is failing due to the failure of the hardware. – Ramhound Dec 30 '20 at 4:30
  • I have physically replaced the drive by connecting the new SSD and disconnected the old HDD. I plug in the recovery disk and start up the computer. I get options for "Recover from a drive" but those options fail with the message, "There was a problem resetting your PC. No changes were made.". – SteveC Dec 30 '20 at 15:06
  • You cannot reset your Windows installation if you have installed a new storage device – Ramhound Dec 30 '20 at 18:54

Buy another SATA cable for old HDD , install SSD , Create new usb windows 10 installation USB using Microsoft USB tool and Windows 10 iso (download from Microsoft) ,disconnect faulty drive , reinstall windows on SSD .Reconnect HDD and manually copy files from HDD drive (D:\Users\Nameofuser\ (all these files on old drive /mount point) into SSD(assume its drive c , so C:\Users\Newuser)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.