22

CompatTelRunner.exe automatically runs without my consent nor my acknowledgement. It periodically shows up and uses RAM and CPU intensively and uses up system HDD I/O bandwidth, rendering my computer unusable (even browsers become very slow to respond).

I was forced to join some program automatically upon installation of Windows 10 unknowingly. It sends data back to Microsoft without consent. This kind of actions is clearly infringing privacy.

I want to permanently and actually disable it. Settings app doesn't allow it. I don't want to delete it because it would be easily restored by sfc. I didn't find a setting that disables it.

How can I prevent it from running?

2

2 Answers 2

17

Thanks to info @BenN gave, I was able to find and disable it, and I have written a cmd command that does this so I can just copy and paste it(and press Enter) to do the job:

schtasks /change /disable /tn "\Microsoft\Windows\Application Experience\Microsoft Compatibility Appraiser"

After some Google searching I found another solution:

reg add "HKLM\Software\Policies\Microsoft\Windows\DataCollection" /v "AllowTelemetry" /t REG_DWORD /d 0 /f

Yeah, I didn't pay enough effort to research this before posting the question, my fault, but sometimes Google is useful, most of the time Google IS NOT useful...

All the search results show only "Microsoft Compatibility Appraiser", but there are four tasks in that folder, the other three: PcaPatchDbTask, ProgramDataUpdater and StartupAppTask, also I had found tasks responsible for running SettinSyncHost.exe, I disabled all of them to ensure they are properly disabled, if anyone else want to disable "Microsoft Compatibility Telemetry" and "Host Process for Setting Synchronization", just copy the below commands into a running elevated cmd(Win+R->type cmd->Ctrl+Shift+Enter):

reg add HKLM\Software\Policies\Microsoft\Windows\DataCollection /v "AllowTelemetry" /t REG_DWORD /d 0 /f
reg add HKLM\SOFTWARE\Policies\Microsoft\Windows\SettingSync /v "DisableSettingSync" /t REG_DWORD /d 2 /f
reg add HKLM\SOFTWARE\Policies\Microsoft\Windows\SettingSync /v "DisableSettingSyncUserOverride" /t REG_DWORD /d 1 /f
schtasks /change /disable /tn "\Microsoft\Windows\Application Experience\Microsoft Compatibility Appraiser"
schtasks /change /disable /tn "\Microsoft\Windows\Application Experience\PcaPatchDbTask"
schtasks /change /disable /tn "\Microsoft\Windows\Application Experience\ProgramDataUpdater"
schtasks /change /disable /tn "\Microsoft\Windows\Application Experience\StartupAppTask"
schtasks /change /disable /tn "\Microsoft\Windows\SettingSync\BackgroundUploadTask"
schtasks /change /disable /tn "\Microsoft\Windows\SettingSync\NetworkStateChangeTask"

No, it's harder than I thought, use https://docs.microsoft.com/en-us/sysinternals/downloads/psexec to run the commands as TRUSTEDINSTALLER to get rid of access denied error, download the file, put it into C:\Windows\System32 and run this command before running the commands I previously gave:

psexec -S cmd
3
  • 1
    It seems that the "BackgroundUploadTask" and "NetworkStateChangeTask" items no longer exist on Windows 11, and that the remaining items are not disabling CompatTelRunner. Additionally, CompatTelRunner does not appear in the Windows Task Manager, but does appear in Sysinternals ProcMon.
    – Dwedit
    Commented Jul 15, 2022 at 17:53
  • 1
    @Dwedit, thanks, I work on Windows 11 (Home, Single language, 21H2), it shows CompatTelRunner (i.sstatic.net/0vlIO.png).
    – CoolMind
    Commented Dec 1, 2022 at 7:48
  • On my Windows 10 system I had to disable the "Program Compatibility Assistant Service" (PcaSvc), in addition to the above, to get it to stop using 100% CPU 100% of the time.
    – AlexPi
    Commented Apr 9 at 23:15
10

Open Task Scheduler, navigate to the Task Scheduler Library → Microsoft → Windows → Application Experience folder using the folder tree, right-click the "Microsoft Compatibility Appraiser" scheduled task, and choose Disable.

1
  • For me that used to work but, like the undead in a horror movie, the darn thing is back :-(
    – Simon F
    Commented May 30 at 7:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .