2

I use an Edgerouter ERX as my main router which is connected to an Arris cable modem (set to bridge mode). There are some devices connected by cable (eg. Synology NAS, Desktop Computer,...) and there is a Netgear R7800 also running OpenWRT configured as my WIFI AP.

This configuration works fine if the Edgerouter is running EdgeOS or OpenWRT 18.06. But as soon as I install OpenWRT 19.07 the router freezes randomly about once a day.

I read, that sometimes there are overheating issues, but when heating up the device deliberately I could not provoke a freeze. I also tried using a different, more powerful power adapter but the freezes still occur (I used a 12V power supply but haven't tried PoE yet). Logging to a remote log server did not give any useful information either.

Has anyone else experienced similar issues or is there something I could still try to figure out the cause of the problem?

2
  • As suggested somewhere I tried to do a clean reinstall of OpenWRT following the instructions on the device page (starting with a custom image vor 19.07.2 and then flashing the official release). I used 19.07.2 until it froze (also hardware flow offloading did not work with this release) and also tried to upgrade to 19.07.5 which also kept freezing. In a next step i flashed the current snapshot release (Kernel Version 5.4.86) which is running without an issue for 24h. Today also a PeO power supply arrived, but I have not installed it yet.
    – Bruno
    Jan 7, 2021 at 11:40
  • I did not check the major differences between 19.07.5 and the snapshot but i already noticed, that the switch configuration changed. It seems DSA driver is used now.
    – Bruno
    Jan 7, 2021 at 11:41

1 Answer 1

1

This thread discusses the issue in depth and confirms that the current snapshot release solves the problem.

3

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.