0

Since a few weeks ago, I've encountered this issue. When I click a URL in an text editor or in our instant messaging app on Windows 10, it invokes Microsoft Edge(Chromium) and %20--disable-features=RendererCodeIntegrity is always automatically appended to the URL. Of course it fails with 404. For example, after I click www.google.com, the address bar has https://www.google.com/%20--disable-features=RendererCodeIntegrity.

Besides, I've configured to use Microsoft Edge to view PDFs. Whenever I double-click a local PDF file, %20--disable-features=RendererCodeIntegrity is automatically appended to the path in the address bar. It's quite annoying as I have to remove %20--disable-features=RendererCodeIntegrity manually every time.

The non-Chromium Microsoft Edge 44.18362.1.0 does not have this issue. My ME version is 88.0.705.29 beta (64 bit). The target field in ME shortcut property has the value "C:\Program Files (x86)\Microsoft\Edge Beta\Application\msedge.exe" --profile-directory=Default. I searched edge://flags/ and didn't find anything related to RendererCodeIntegrity.

Thanks.

7
  • Can it be caused by some add-on?
    – harrymc
    Jan 4 at 12:57
  • @harrymc thanks. I have only installed one add-on. After removing the add-on, the issue still exists.
    – ElpieKay
    Jan 4 at 13:02
  • What are the values of these registry keys: HKEY_CLASSES_ROOT\MSEdgeHTM\shell\open\command and HKEY_CLASSES_ROOT\MSEdgePDF\shell\open\command? Jan 4 at 13:05
  • @ReddyLutonadio thanks. Both are "C:\Program Files (x86)\Microsoft\Edge Beta\Application\msedge.exe" --single-argument %1.
    – ElpieKay
    Jan 4 at 13:11
  • These are the correct values. Something is injecting that command line switch. --disable-features is listed here among Chromium command line switches. Jan 4 at 13:15
1

Try to reset Microsoft Edge:

  • Start Settings > Apps > Apps & features
  • Click on "Microsoft Edge"
  • Click the Modify button
  • Allow execution and reboot.

If this still happens, try to enter the following command in PowerShell that is Run as Administrator and reboot:

Get-AppXPackage -AllUsers -Name Microsoft.MicrosoftEdge | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml" -Verbose}

If the problem still happens, then it is caused by the applications you are using. Try to find some pertinent configuration options in your text editor or in the instant messaging app.

2
  • Thanks. I tried both methods and neither worked. BTW, the quotation marks in the command are not proper.
    – ElpieKay
    Jan 5 at 9:59
  • 1
    Fixed the quotation marks - the hazards of copy-paste. You could also try general troubleshooting: sfc and DISM. Or even In-place Upgrade (which might be too heavy so check the apps first).
    – harrymc
    Jan 5 at 10:04
0

I got same issue. It's caused by third-party components in exploer.exe. Exploer.exe called edge with below command line:

"C:\Program Files (x86)\Microsoft\Edge\Application\msedge.exe" --single-argument https://www.bing.com --disable-features=RendererCodeIntegrity

Then Edge will add "%20--disable-features=RendererCodeIntegrity" to the URL.

The third-party component is IP-Guard.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.