0

My Windows 10 had suddenly entries of three Chinese languages in the language bar, without me having them installed.

enter image description here

They are not present in the keyboard layout, so I cannot uninstall them.

enter image description here

The culprit may be related to MS Word because in its proofing language section, Chinese(Taiwan) has appeared without me having installed it. enter image description here

However, this may just be a side effect of other system options because in the MS Word language options, Chinese does not appear.

enter image description here

I have seen this and this old thread but I am not able to translate the suggested solutions into a Win10 environment. I was neither able to locate the mentioned registry keys nor the Office 2010 installed IMEs in the corresponding Microsoft Word 365 environment.

I installed Chinese/Taiwan as a language option via Windows display language - it appeared as a fourth Chinese language entry in the language bar, so uninstalling it afterward, did not solve the problem.

This thread was marked as a duplicate, alas it is not. The first method of the supposed duplicate answer does not work, as I explained because the Chinese languages are not listed as language options.

The second method looked promising. Indeed, under HKEY_CURRENT_USER\Keyboard Layout\Preload (but not in the other three mentioned registries) were three Chinese keyboard codes listed. I deleted them and restarted. The Chinese keys are now deleted...

enter image description here

but the three Chinese entries still exist in the language bar. enter image description here

While scrutinizing the options in Setting, I noticed that the languages are also mentioned under advanced keyboard settings but you can only change here their hotkeys.

enter image description here

5
  • "The culprit is most likely MS Word" - Can you provide a screenshot of the languages that Microsoft Word believes to be installed? Additionally, have you tried to uninstall Office (then reinstall it), since you believe that to be the culprit? – Ramhound Jan 11 at 15:27
  • Thank you for the suggestion but on second thought, Word may just reflect some system changes (see update). I work with Word 98% of my working time, it is a well-established and personalized installation linked with other programs, and I will not uninstall and then not be able to work for days because new problems arise after the reinstallation. So, this is out of the question. – Mr. T Jan 11 at 15:46
  • If you are unwilling to perform that simple test then I will be unable to help you. – Ramhound Jan 11 at 16:02
  • Due to the gold tag I have in Windows 10 I am indeed the reason the question is reopened. You will want to be more willing to try solutions and/or provide information otherwise your question will eventually be closed again. I have one suggestion but won't be able to research it for at least 36 hours. – Ramhound Jan 11 at 16:09
  • Thank you for looking into this. It is of no urgency - the main problem is that I switch input languages with a keyboard shortcut, and the three unnecessary language entries interfere here. – Mr. T Jan 11 at 16:20
0

Remove the extra language from:

Regedit Computer\HKEY_USERS.DEFAULT\Keyboard Layout\Preload

Language CODE https://www.science.co.il/language/Locale-codes.php

Regestry

1
  • Thank you for the suggestion. There were indeed three entries for the Chinese language. I delete the keys, restarted but the Chinese language options still remain in the language bar. – Mr. T Jan 11 at 10:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.