In VMware workstation 16 player, running "adb devices" in the guest OS, doesn't show smartphone device.

But guest OS can see it for file transfer

enter image description here

Same situation with another smartphone I tried it with

enter image description here

So it's not an issue with one smartphone in particular. It happens with both of them.

And in both cases, when looking at them in the host OS, (so, when not setting vmware to switch them to the guest OS), then , from the host OS, adb devices works.

I have used VMWare Player, though a friend once mentioned that he thought maybe the same issue may be in VMWare workstation Pro.


A commenter suggested that it may require adding multiple devices.. e.g. if a phone may come up as a hub too. But not in this case.. For example, in the case of my Moto G7 Power Smartphone, it doesn't include additional devices.. the only other "Removable devices" listed, are a smartcard reader and a webcam, which have nothing to do with the smartphone, and which VMWare lists anyway even if I unplug the smartphone. And if I switch the smartphone to the Oppo smartphone then ditto, still. The only device that it comes up as is that. The other devices mentioned are smartcard reader and integrated webcam which are there anyway even if I were to unplug the smartphone.

  • Have you definitely passed the USB devices through to the guest? docs.vmware.com/en/VMware-Workstation-Pro/16.0/… via VM > Removable Devices > Device Name > Connect (Disconnect from host) – Mokubai Jan 15 at 9:03
  • @Mokubai yes definitely, hence as mentioned I can transfer files, and hence as mentioned re setting vmware so as to switch the USB device from host machine to guest machine – barlop Jan 15 at 9:04
  • Phones may show up as multiple devices and a hub, you may need to let multiple devices through, not just MTP. It would be worth showing the passthrough settings you are using. – Mokubai Jan 15 at 9:05
  • @Mokubai it's just that device.. – barlop Jan 15 at 9:26
  • @Mokubai regarding MTP or PTP.. My Moto G7 shows "file transfer", "usb tethering", MIDI, PTP, "no data transfer". . I have PTP selected. When on my host system adb devices is fine. I don't have the word MTP listed on there – barlop Jan 15 at 9:26

Turned out it wasn't a VM issue. It was an issue with the windows installation itself not including proper support for the adb devices command to work. The solution was

the "universal android driver", https://adbdriver.com/

that worked on getting windows to detect either smartphone.. for my moto phone it saw Motorola.. And for my (not recommended) Oppo smartphone, the software detects it as a generic thing like Android Composite ADB Interface, and clicking install gets it recognised by adb devices

On my host computer I had no problem, maybe because it had android studio on there and maybe in setting that up(which included me downloading adb platform and a manager for it), maybe that set the adb driver up properly along with downloading the adb platform, though I don't know if that's 'why' a fresh Win7 ISO doesn't recognise it and my host computer does. But either way, a computer that doesn't recognise it can be made to with that 'universal adb driver' on adbdriver.com

enter image description here

Apparently another adb driver installer might be https://github.com/koush/UniversalAdbDriver which links to https://adb.clockworkmod.com/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.