11

There is this quite annoying bug, which is probably related to Windows 10, which makes mobile CPUs clock down to 0.39 GHz/399 MHz. Just searching on Google for "0.39 GHz". There are so many results with this exact problem.

My brand new Lenovo ThinkPad T15 has this problem as well with its i7-10510U CPU. However, it gets a bit weirder than that. Even when the CPU is running at 100% on all 4 cores/8 threads, Windows still manages to say "nope, this PC is definitely sleeping". Just take a look (although it's at 499 MHz and not 399 MHz here):

enter image description here

As you can see, all cores are maxed out, yet the CPU is still heavily underclocked. The temperature is fine - it rarely hits 90-95 degrees, where throttling would start to occur.

So I did a couple of things:

  1. Turn performance slider in Windows to Maximum Performance
  2. Open BIOS and disable CPU Power Management (which has some smart measurements that turns the CPU clock speed and voltage down when it THINKS it's asleep)

That seemed to help and I rarely get stuck at 0.39 GHz again.

HOWEVER, the laptop basically sits in a corner while I work, because I RDP into it from my desktop PC, which has more monitors, better keyboard, and so on. It works great. However, when the screen goes to sleep/turns black, it instantly sets the clock speed to 0.39 GHz again.

So now I have to either choose between having a CPU running at 0.39 GHz OR a CPU running at 4.3 GHz basically all the time, but the screen is turned on at the lock screen, so it might burn in after a while.

I'm tech savvy and I need some answers, so please, fire away. Why is the CPU "sleeping" at extremely low clock speeds, when the CPU hits 100% utilization? Why does Windows 10 or the laptop think it's okay to tell the CPU to "sleep"/preserve power, when the screen is turned off but I am actively using the PC via RDP? Is there a fix to this? So many questions and nobody has the answer, according to the 20+ sites I've went to.

9
  • superuser.com/a/1579923/19943 suggests that rebooting while on charge might help, there are other answers there as well
    – Mokubai
    Jan 15, 2021 at 20:41
  • other potential duplicates: superuser.com/questions/1241844/… and superuser.com/questions/1598516/…
    – Mokubai
    Jan 15, 2021 at 20:43
  • @Mokubai Didn't work. Already tried. Last link shows a couple of things that I already tried. I do not have minimum/maximum CPU state in my power settings, so that's also not an option. This might be a duplicate, but I'm HOPING someone has an answer, because all other answers did nothing. Jan 15, 2021 at 21:41
  • Have you read every answer to all those potential duplicates?
    – Ramhound
    Jan 15, 2021 at 23:13
  • @Ramhound Yes, yes I have. And more. A lot more. I can't begin to explain how many sites I've visited and tried. Jan 16, 2021 at 1:03

8 Answers 8

3

EDIT: Nope, this did not fix my issue. It seems to be somewhat more stable when the screen is on, however, so I'm keeping it up if someone stumbles upon it.

So I think I managed to find a solution to my problem. Windows has introduced a feature called Modern Standby.

To check if Modern Standby is enabled, open CMD and write powercfg /a. If you see a Standby (S0 Low Power Idle) Network Connected option under available states, you have Modern Standby enabled.

The following sleep states are available on this system:
    Standby (S0 Low Power Idle) Network Connected
    Hibernate
    Fast Startup

The following sleep states are not available on this system:
    Standby (S1)
        The system firmware does not support this standby state.
        This standby state is disabled when S@ low power idle is supported.

    Standby (S2)
        The system firmware does not support this standby state.
        This standby state is disabled when S@ low power idle is supported.

    Standby (S3)
        This standby state is disabled when S@ low power idle is supported.

    Hybrid Sleep
        Standby (S3) is not available.

To disable this, you can do a few things. If you're running Windows 10 2004 or before (I think), you can add a CsEnabled registry and set it to 0. If you're running 20H2 or newer, it should be PlatformAoAcOverride.

reg add HKLM\System\CurrentControlSet\Control\Power /v CsEnabled /t REG_DWORD /d 0

or

reg add HKLM\System\CurrentControlSet\Control\Power /v PlatformAoAcOverride /t REG_DWORD /d 0

After running one of the above commands and rebooting, it should disable the S0 state:

C:\Users\Username>powercfg /a
The following sleep states are available on this system:
    Standby (S3)
    Hibernate
    Hybrid Sleep
    Fast Startup

The following sleep states are not available on this system:
    Standby (S1)
        The system firmware does not support this standby state.

    Standby (S2)
        The system firmware does not support this standby state.

    Standby (S0 Low Power Idle)
        The system firmware does not support this standby state.

Resources:

Once that is done and S0 is disabled, you should be able to edit your Power Options, so you can set the Processor power management:

Power Options window with following settings: Minimum processor state: 100%, maximum processor state: 100%, system cooling policy: active

3
  • @gronostaj I know that. That's why everything related to this issue was written as text, and the images was provided as additional information. The screenshots only provide visual representation of what it should look like, but the relevant information is written in text. Jan 19, 2021 at 9:39
  • So visually-impaired visitors with the same issue who will attempt to apply your solution won't know what it should look like. Posting terminal screenshots has no advantage over plain text. Your font and color settings are not relevant, it's the content that's important.
    – gronostaj
    Jan 19, 2021 at 9:50
  • 2
    @gronostaj I disagree and I won't change it. The screenshots aren't a critical feature of this answer. It's not like I wrote "it should look like this", "go write these commands" and posted screenshots of them. Arguing about whether or not an answer should contain screenshots or not, is a stupid discussion that I simply will not waste any more time on. Thanks. Jan 19, 2021 at 9:55
1

Recently had this issue with one of my Lenovo laptops. Lenovo investigated and said it was an issue with the "Modern Standby" feature.

The fix was to update to the latest Lenovo Inteligent Thermal Solution driver (version: 2.0.369.1) and to disabled "Modern Standby" with this Registry Key:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LITSSVC\IC\CONFIG] "MSC"=dword:00000000

Let me know if that works for you :)

1

I had very similar issue at my Lenovo T14 gen.1 (windows 10 ver. 1909). I fixed it. Thanks a lot to @MortenMoulder and @Sendi !

I did the following changes:

  1. BIOS upgraded from 1.17 to 1.19 (this fixed low clock freq. after wake-up)

  2. Drivers upgraded (not sure which exactly helped as I applied many upgrades in one go; there were couple upgrades to power and thermal related devices)

  3. Changed registry as follows (this with driver upgrades fixed low clock frequency during screen-off state !!!)

    [HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LITSSVC\IC\CONFIG] "MSC"=dword:00000000

Disabling Modern Standby ("CsEnabled"=0 or "PlatformAoAcOverride"=0) did not help to avoid slow work when the screen is off, but had some other benefits (like all processes stop fully if you put your PC in sleep mode).

Neither helped increasing Minimum Processor state in Power Options, disabling Intel Speed Step and CPU Power management in BIOS (I didn't see any effect from these changes at all).

Changing Windows Power Mode from Better Performance to Best Performance increased CPU clock frequency but did not help against slow work during screen-off state.

0

Download hardware monitor and check temperatures of your CPU.

I have had the exact same problem.

The fan is not functioning and the CPU is forced to downgrade the frequency because of that.

Why does my CPU utilization differ in Hardware Monitor and Task Manager?

That's actually the problem. Replacing the fan works.

2
  • 1
    That's definitely not true. The CPU temperature was perfectly fine. Apr 7, 2021 at 7:38
  • Your symptom is exactly the same as mine. How do you know the CPU temperature is fine? Did you download hardware monitor?
    – user4951
    Apr 7, 2021 at 15:55
0

If it's a Lenovo laptop T15 pc make sure you have BIOS 1.34 or newer since the fix for "(Fix) Sync TX solution to fix BIOS does not issue ATA FreezeLock / BlockSID during resuming from Modern Standby" have been introduced. This should fix the problems for the slow PC 0.39Ghz problem.

0

I have the same issue when I RDP, but with a Carbon X1 Gen 9. I did not have the registry key that Sendi mentioned after installing the Thermal Solution driver.

I have found that the CPU fan turns off when the Screen turns off, whether the laptop lid is open or closed. When the screen goes to sleep, you can wake up the system. If I set the screen turn off time to 1 min, the CPU fan will cut off after a minute. Tested with 3 and 5 as well, and the link is 100%

As a current workaround, under Power & Sleep, I have set the "When plugged in, turn off after" to Never.

-1

If it can help, I solved this issue on my Thinkpad X270, which had the same issue, by booting the laptop plugged in. That "disabled" the bug and now, even if I'm not plugged in (at boot or in general), no problem anymore.

-1

For me.I use AMD cpu.I removeed intel and set amd registry but still not help.

I use internet from my phone(Samsung S21) vie usb tethering connect with a type-c fast charge cable. I found my CPU speed lock to 0.39GHz when I dont use internet and random lock when network running. I guess it because the phone switch sending network data and power. And laptop doesn't how to handle small power from phone then lock cpu powerusage to minimal(watts).

So when I unplug my phone, I see the CPU doesn't lock anymore. Maybe you should check all power source that connect to your laptop.

Not the answer you're looking for? Browse other questions tagged or ask your own question.