3

I installed Alacritty and its cool and all but because of my ZSH shell (I'm on Manjaro Gnome). It has a lot of emojis and it cuts some of those visuals:

enter image description here

Here is the native gnome terminal:

enter image description here

5
  • Have you tried changing the font settings? See .config/alacritty/alacritty.yml · GitHub
    – DavidPostill
    Commented Jan 22, 2021 at 16:38
  • No. I have no idea how to do that. I have never done it for a terminal. How should I do that?
    – John
    Commented Jan 22, 2021 at 18:10
  • You edit the file and then restart your terminal
    – DavidPostill
    Commented Jan 22, 2021 at 18:12
  • @DavidPostill Perhaps you could tell which file? Commented Jan 23, 2021 at 21:05
  • I told you above .config/alacritty/alacritty.yml in your home directory
    – DavidPostill
    Commented Jan 23, 2021 at 21:07

1 Answer 1

5

Update March 2024

Alacritty now uses TOML as configuration file format. So the appropriate configuration would be:

[font]
offset.x = 0  # For letter spacing (default: 0)
offset.y = 0  # For line spacing (default: 0)

You can get a complete documentation about the configuration here.

Old answer

Put these settings in font section in your ~/.config/alacritty/alacritty.yml:

# NOTE: Values can be changed.
font:
  offset:
      x: 0    # For letter spacing (default: 0).
      y: 0    # For line spacing (default: 0).

See more at alacritty's documentation.

0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .