0

I own an external HDD on which I installed a game from the Windows App store. My laptop got reset at some point and now the Windows App store wont recognize that it is installed there. I have tried to Manually Register the package via an administrator Powershell prompt, but it just returns an error about permissions. Does anyone have any idea on how I could register this package?

The command I used:

Get-AppxPackage | % { Add-AppxPackage -c -Register "D:\WindowsApps\Microsoft.SeaofThieves_2.95.2035.2_x64__8wekyb3d8bbwe\AppxManifest.xml" -verbose }

The Result:

Confirm
Are you sure you want to perform this action?
Performing the operation "Register package" on target
"D:\WindowsApps\Microsoft.SeaofThieves_2.95.2035.2_x64__8wekyb3d8bbwe\AppxManifest.xml".
[Y] Yes  [A] Yes to All  [N] No  [L] No to All  [S] Suspend  [?] Help (default is "Y"): Y

Add-AppxPackage : Deployment failed with HRESULT: 0x80070005, Toegang geweigerd.
error 0x80070005: Opening file from location: AppxManifest.xml failed with error: Toegang geweigerd.
.
NOTE: For additional information, look for [ActivityId] 4a766b3f-fac4-0004-1f28-774ac4fad601 in the Event Log or use th
e command line Get-AppPackageLog -ActivityID 4a766b3f-fac4-0004-1f28-774ac4fad601
At line:1 char:23
+ ... ckage | % { Add-AppxPackage -c -Register "D:\WindowsApps\Microsoft.Se ...
+                 ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
    + CategoryInfo          : SecurityError: (D:\WindowsApps\...ppxManifest.xml:String) [Add-AppxPackage], PSSecurityE
   xception
    + FullyQualifiedErrorId : DeploymentError,Microsoft.Windows.Appx.PackageManager.Commands.AddAppxPackageCommand

VERBOSE: Operation completed for: D:\WindowsApps\Microsoft.SeaofThieves_2.95.2035.2_x64__8wekyb3d8bbwe\AppxManifest.xml
7
  • it looks like you are running the register command ON EVERY APP and pointing all of them at the same thing. is that what you intend?
    – Lee_Dailey
    Feb 4 at 15:48
  • No, I just want to register Sea of Thieves Feb 5 at 19:55
  • 1
    your command pipes ALL the results from Get-AppxPackage to the ForEach-Object. that runs the same command _once for every AppxPackage. that seems at least somewhat problematic.
    – Lee_Dailey
    Feb 6 at 0:49
  • Im not very familiar with powershell formatting, but I dont see what you mean, could you explain what you mean? Feb 8 at 9:51
  • 1
    this >>> Get-AppxPackage | % { Add-AppxPackage <<< is sending ALL of your packages to the next pipeline stage. then you are doing a ForEach-Object [aka - %] on a single command that acts on just the one thing. WHY are you doing that? why don't you just use the Add-AppxPackage command on just the one package?
    – Lee_Dailey
    Feb 8 at 14:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.