0

I have a known-good Clonezilla backup of the C: partition (Windows 7) that I wish to restore to a new, clean SSD drive. (Known-good means that I restored this image a few times before, and the restore was always successful -- and Windows 7 and all apps operated just fine).

Background:
I partition my drives, putting all data on the D: partition which allows me to re-image the C: partition as desired. Restores of the C: partition always work and solves Windows bloat and any stability issues. What is different this time is that I am not over-writing the existing C: partition, I am restoring to a newly-purchased, clean SSD that I prepared using GPartEd.

How I prepared the new SSD:
On the new, clean, SSD I created a C: partition (Primary) that is slightly larger than the C: partition on the old drive, and the rest as D:. Both partitions were created as Primary partitions but nothing else was done, no formatting etc.

Problem Description:
After restoring the C: partition via Clonezilla, the new SSD will not boot. It gives the error "Invalid partition table!" I tried rebooting with GPartEd and marking the new SSD's C: partition as "boot" but that didn't fix it (it still won't boot - there is no error message now, just a blinking cursor at top left). My old drive still works just fine and I can use it to effect a solution (if I knew what to do...)

What should I do to make the new SSD drive bootable?

2
  • Why don't you install Windows to the SSD, making sure the system partition is the same size as your current system partition, then restore the image to that partition like you normally do? – Ramhound Feb 8 at 15:50
  • Funny you should mention... After writing this question, I thought about that and I tried it. The message that I now get is "Windows failed to start... to fix the problem insert your Windows installation disc, boot from that and choose Repair Your Computer - so I am trying that.I am following instructions from here – cssyphus Feb 8 at 15:59
0

I was able to solve this problem using Method 3 at this Superuser post. I had to run the fix more than once. The author (Mohammadhassan Esfahanian) skips a couple of steps (on my media), so I will be very detailed for the novice:

  1. Boot from Windows 7 installation DVD/USB

  2. Accept language

  3. Repair your computer (very small, at bottom left of logo/splash window)

  4. Troubleshoot

  5. Advanced Options

6a) First, try Startup Repair (try 3x if not work the first time)
(Attempting Repairs might conclude "Cannot repair..." try again then move to 6b)

6b) If 6a does not fix, use Command Prompt and follow Mohammadhassan's instructions (same link). Note that he says that you might have to repeat more than once - I ran StartRep four times (and never saw any sort of SUCCESS message - each time it said that it could not repair the PC)

But despite the Cannot Repair messages, it worked! Thank you Mohammadhassan.

References: (#2 same link)

Where to download legit installation media

The boot selection failed because a required device is inaccessible 0xc000000e

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.