I'm having a bizarre problem with our internet connection in our temporary house. We have been given a cable modem with (i believe comcast) internet connectivity.

If i plug my macbook pro directly into the modem, it offers up an IP address with DHCP and everything works fine. However when I connect my wireless router (linksys wireless n), it is never able to receive an IP address from the modem. I thought this was strange, so I ordered a new router from our housing people. They gave us a netgear router, and the same result occurred - no internet.

Finally, I plugged our other laptop (Windows vista) directly into the modem, and still no internet. Any thoughts on what is going on here? Why is my macbook pro the only device out of 4 that is able to get an IP address from the modem?



1) was the modem reset between connecting devices? oddities can result from the fact that the modem is, in most configs, only allowed to assign one IP address.

2) did you set up the modem with the macbook pro connected to it? some ISPs set modems to remember the MAC address of the machine on which they were set up, and then ignore others. Your router probably has a MAC Clone function, which you might want to use to clone the ethernet MAC of the macbook to see if that clears it up.


Try setting the router to use your MacBook's MAC address. The modem or ISP might lock to the first MAC address used.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.