1

Summary: If I press Ctrl+Shift with the Ctrl key being pressed the tiniest fraction of a second before Shift, then the combination works as expected for things like highlighting words with Ctrl+Shift then right or left arrows. If the Shift key contacts ever so slightly before the Ctrl key, the combination does not work. When the Shift key is pressed first, the arrow keys do nothing (don't move the cursor and don't highlight)

Details:

Ubuntu: 20.04.2 LTS
Gnome: 3.36.8
kernal: 5.8.0-43-generic
ASUS UX461U notebook

In any text input (gedit, chrome address, VS Code, etc...) I type some text, then hold Ctrl-Shift then press the left or right arrow. If the Ctrl hits first, it works, if the Shift hits first the cursor does nothing (the cursor does not move at all when pressing the left or right arrow). The timing is so small (I thought I was pressing Ctrl-Shift simultaneously) it took me a long time to figure out why it worked sometimes and not other times.

Tests:

  1. If I boot under windows 10 it works fine
  2. I have tried various USB keyboards, and tried with only the built-in keyboard. The results are all the same.
  3. I have no USB dongles attached.
  4. Strangely, I found that when I press the Super (Windows) key for the activities screen, then type into the "type to search" bar at the center top of the screen, the key Ctrl+Shift combination works when pressed in either order. Maybe that input is outside of Gnome or something??
  5. The key press order issue only applies to left Ctrl+Shift. Right works regardless of order.

I'm training myself to press the keys in order, but I would love to know what is going on. Any tests, or advice is appreciated.

1
  • Cannot reproduce on my desktop; Logitech MK120 keyboard/mouse, ASUS MB++, Ubuntu 20.04.2 LTS, gnome 3.36.4-1ubuntu1~20.04.2, kernel 5.8.0-43-generic
    – Hannu
    Feb 20, 2021 at 12:38

1 Answer 1

2

I met the same issue with GNOME 3.38.3. Besides, I noticed the weird behavior only appears when exactly one of the CapsLock or NumLock is on.

It turns out the cause on my system is that I enabled the "Locate Pointer" feature (highlighting the pointer's location with left Ctrl, Gnome Settings -> Accessibility -> Pointing & Clicking -> Locate Pointer). Turning it off solved my issue.

1
  • This is the answer. Thank you! I turned it off with: gsettings set org.gnome.desktop.interface locate-pointer false
    – Gronk
    Feb 22, 2021 at 11:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.