0

I need to run memtest86 because my ram is going bad and I want to pinpoint which one it is. I don't know how to change from legacy to UEFI, (which is apparently necessary and I've no idea of the easiest way to do it.) and when I tried following directions to use diskpart I ended up being told "Cannot find OS Partition(s) for disk 0". I know that my OS is on disk "1" but I don't know what to do from here. If It's checking specifically disk "0" Do I need to switch the partition disk labels? Would it be easier to just unplug my storage drive for now? Any help is appreciated.

1
  • 1
    Do NOT use diskpart. That’s one of the best ways to lose all your data if you don’t k ow what you are doing. If you wipe your data with diskpart, it’s gone, end of story
    – Ramhound
    Feb 20, 2021 at 15:16

3 Answers 3

3

If you cannot find out how to switch to UEFI booting or your PC simply does not support it, the download page is pretty clear:

MemTest86 V9 images support only UEFI boot. On machines that don't support UEFI, MemTest86 will not boot. Please download the older V4 BIOS release of MemTest86 instead.

(Emphasis mine)

So scroll down to “Older Versions” and get a compatible version from there.

0

Use this site

Memtest86.exe

Go down to the Features section and make a bootable USB Key.

Do not change your PC setup (you may need to disable Secure Boot in BIOS)

Do not try to run Memtest86 from the operating system.

enter image description here

6
  • When I boot I've tried a few things. I let it boot on it's own with the USB in, and it just boots to windows. I've gone to the boot selection screen and I have a few choices. USB FDD, USB ZIP, USB CD, and USB HDD. Then legacy LAN. Those options either boot me to the desktop or they stick on "Loading operating system".
    – Freed88
    Feb 20, 2021 at 15:45
  • Make sure you (temporarily) disable Secure Boot, and then start with the Bootable USB I outlined and then it should not try to load the operating system. Please clarify your question as to (a) using Memtest86 which I responded to or (b) starting your computer without Memtest86.
    – John
    Feb 20, 2021 at 15:49
  • I tried looking in the bios directly and to shift click on restart to enable it that way but there was no option in either place that led to that. I don't have a UEFI option on my restart screen.
    – Freed88
    Feb 20, 2021 at 16:05
  • Then just make the Memtest86 USB key and start with it. I am unclear if you are try to test Memory or start your computer. 2 different things.
    – John
    Feb 20, 2021 at 16:06
  • I want to test memory. When I boot it doesn't seem to boot into the usb even when I tell it to. The info page on memtest says "Note: The UEFI BIOS must be configured to boot from the device that MemTest86 is installed on." But I am on legacy, which is why I was trying to use diskaprt to book into UEFI. I don't really know the best way to do that.
    – Freed88
    Feb 20, 2021 at 16:08
0

Windows has an integrated memory test Technology

just goto Start, sesrch for problem with ram

after this starting the guide will tell you to restart your computer and then the test veginns

See as refernce here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.