1

Been pulling my hair out on this one.

Have a brand new Sandisk 32GB Extreme Plus SDCard. I've been trying to get an image on it to work (for my Raspberry Pi 4). When I bought it, I used balenaEtcher to flash HassOS (home assistant OS) on it.

When I plugged in my sdcard on my Rasperry Pi for the first time, I hooked my Pi up to a screen and saw the terminal text. There was some errors that popped up (I don't recall what it was, some Golang errors), so I thought to try and reflash the image.

I took it out, put it in my sdcard slot (on my CalDigit dock) and attempted to flash it again using BalenaEtcher. But I got a strange Checksum error. So I tried to format the SDCard, but I've been getting errors on everything I'm trying.

I've tried: I've tried DiskUtility, diskutility and hitting "Erase" choosing various options (MSDOS-FAT) for example gives this error:

Formatting disk2s2 as MS-DOS (FAT) with name UNTITLED
512 bytes per physical sector
/dev/rdisk2s2: 49020 sectors in 12255 FAT16 clusters (2048 bytes/cluster)
bps=512 spc=4 res=1 nft=2 rde=512 sec=49152 mid=0xf8 spf=48 spt=32 hds=16 hid=67584 drv=0x80

Mounting disk
Could not mount disk2s2 after erase

And hassos-boot still remains!

I downloaded SDCardFormatter program to do a quick format, and get this error:

[ERROR] Invalid end of sector signature: 0xA940
[ERROR] fat_check_validate_boot_sector returned error: 22 (Invalid argument)
[ERROR] Initializing cached values failed: 22 (Invalid argument)
[ERROR] Generated invalid volume. fat_volume_create returned: 22 (Invalid argument)

I've tried Raspberry Pi Imager v1.5, and tried erasing the SDcard that way. And I get this error:

The chosen size is not valid for the chosen file system

I've tried diskutil eraseDisk FAT32 MYDISK MBR disk2 and get this error: Error: -69850: The chosen size is not valid for the chosen file system

Tried ExFAT too instead of FAT32 (even though the disk is 32GB) and get this in logs: Formatting disk2s1 as ExFAT with name MYDISK Error: -69830: This operation requires an unmounted disk

I bought a new SD card but it just blows my mind that a brand new SDCard would get screwed up already. Is there something else I should be trying?

6
  • "Have a brand new Sandisk ..." -- "Brand new" IMO really means untested. "And hassos-boot still remains!" -- Sounds like the card has reverted to "permanent" write-protect mode. Maybe you have a counterfeit card?
    – sawdust
    Commented Feb 23, 2021 at 23:46
  • @sawdust What do you mean reverted to permanent write protect mode? What does that mean? I bought this at Microcenter (reputable electronics store around here). Box seems legit... Unsure how to know if it's counterfit for sure.
    – K2xL
    Commented Feb 24, 2021 at 0:33
  • @sawdust you may be on to something, i just tried deleting the files on the sd card manually through Finder. They disappear, but when I eject the sdcard and put it back in they reappear. Weird!
    – K2xL
    Commented Feb 24, 2021 at 0:46
  • I would recommend the app 'unetbootin' for making bootable devices from images. I've had issues in the past with balena etcher on macos, for whatever reason.
    – Hefewe1zen
    Commented Feb 24, 2021 at 1:23
  • Sounds like a classic case of the firmware write protect having kicked in; usually happens on a write error. See superuser.com/questions/1125282/… The card is essentially trash now.
    – Tetsujin
    Commented Feb 24, 2021 at 9:10

0

You must log in to answer this question.

Browse other questions tagged .