0

I'm having an issue with my raspberry detecting the Alfa antenna I got.

I'm trying to configure and get up running the Alfa AWUS036NH on my Kali linux system (Image here. Kali Linux RaspberryPi 2 (v1.2), 3, 4 and 400 (64-Bit)), which is installed on the Raspberry pi 4 model B.

When plugging the Alfa USB cable in the booted pi (I tried all the USB 2 and USB 3 ports), the Alfa signal LED lights up and stays lit. So I am assuming the system is powered up correctly.

I have read that the antenna is supported out-of-the-box by kali, and that it should be detected without further action. Though it looks like it is not on my system, because the antenna is not detected by the system in any way. (I did not install any driver).

I have also connected the raspberry to my local WiFi before inserting the alfa into the raspberry, so I do have an internet connection via the pi's internal network card.

I'm running kali on a headless pi over ssh. The alfa antenna was connected to an USB3 port prior to booting the pi.

kali@kali:~$ iwconfig
wlan0     IEEE 802.11  ESSID:"Vodafone-8473648293"
          Mode:Managed  Frequency:2.427 GHz  Access Point: 74:36:6D:47:3A:3A
          Bit Rate=65 Mb/s   Tx-Power=31 dBm
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          Link Quality=50/70  Signal level=-60 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

lo        no wireless extensions.
kali@kali:~$ ifconfig
eth0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether dc:a6:32:a6:7a:34  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 84  bytes 6680 (6.5 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 84  bytes 6680 (6.5 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlan0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.31  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::a700:d248:d3cb:5d46  prefixlen 64  scopeid 0x20<link>
        ether dc:a6:32:a6:7a:35  txqueuelen 1000  (Ethernet)
        RX packets 77  bytes 7591 (7.4 KiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 69  bytes 10740 (10.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
kali@kali:~$ lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 002: ID 2109:3431 VIA Labs, Inc. Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
kali@kali:~$ sudo airmon-ng
[sudo] password for kali:

PHY     Interface   Driver      Chipset

phy0    wlan0       brcmfmac    Broadcom 43430
kali@kali:~$ uname -a
Linux kali 4.19.127-Re4son-v8l+ #1 SMP PREEMPT Sun Feb 21 13:39:21 UTC 2021 aarch64 GNU/Linux

dmesg stdout: here

The alfa does not show up anywhere, and I can't seem to find a reasonable solution.

Edit 1: after installing Kali 2021 on a notebook and doing the same procedure, the result is the same. Alfa light on, no usb signal, network interface not detected.

Edit 2: downloaded drivers from official website but they do not provide any instruction for compilation, and running make as described in the provided readme does not work. Also tried unsuccessfully installing https://github.com/aircrack-ng/rtl8812au with an error described in issue #774

1
  • 2
    The top priority is that the device appears in the lsusb output. To my knowledge, this does not depend on any software layer of Linux so you might have a USB cable issue, or the device is non-functioning. – xhienne Feb 25 at 16:32
1

it seems you do not have the drivers installed. i did a little research for ya and found these. i hope this is what you need. https://files.alfa.com.tw/?dir=%5B1%5D%20WiFi%20USB%20adapter/AWUS036NH/Linux Also, if you are using a virtual machine, im pretty sure its not very easy to use a usb wifi adapter on that vm. Hope this helps. I would install those drivers just in case even if it says it works right out the box ¯_(ツ)_/¯

2
  • Thank you! This looks promising. Are there instructions on how to install the driver anywhere? – Andrea Feb 28 at 12:12
  • Tried compiling the drivers but they do not compile. See edited post – Andrea Feb 28 at 23:03
0

As @xhienne pointed out, the cable was the issue. Yes. The one who came in the official shipping box from Alfa. It powered the device but (I suppose) did not allow to communicate with the computer. Changed to a new USB-A to USB-B connector and now the antenna works like a charm.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.