PROBLEM: On Ubuntu 20.04 LTS (Server), installing ubuntu-desktop through tasksel fails with error "tasksel: apt-get failed (100)".

SOLUTION 1: Restore last good checkpoint. The simplest solution is to roll back your system to your last good checkpoint and install tasksel then ubuntu-desktop cleanly. If that is not an option for you, see the next solution.

SOLUTION 2: Check that you have tasksel dependencies installed using the commands:

  • sudo apt list --installed debhelper*
  • sudo apt list --installed dpkg-dev*
  • sudo apt list --installed gettext*
  • sudo apt list --installed po-debconf*

If you are missing these packages or they are not the correct version, install/upgrade them. In my case, debhelper was not present. The debhelper package cleans up your machine if partial or conflicting files are present. tasksel actually lists it as a dependency, probably for this reason. Details on tasksel dependencies are here.

System Details: My server is Ubuntu 20.04 LTS (focal) on amd64 architecture on a VM in Hyper-V. The Ubuntu OS is up to date.

Steps to Produce Error:

  • I installed tasksel using sudo apt install tasksel.
  • I called tasksel using sudo tasksel.
  • I highlighted the package "ubuntu desktop" and pressed Enter.
  • Install failed with the error:
  • tasksel: apt-get failed (100)

Remedies Attempted:

  • I checked that /etc/apt/sources.list enabled my focal repos (they are enabled).
  • I tried several combinations of sudo apt update, sudo dpkg --configure -a, and restarting the server. Sources here.
  • After all this, using sudo tasksel and attempting Ubuntu-desktop installation failed with the same error.
  • tasksel: apt-get failed (100)

I checked the Ubuntu tasksel Launchpad page and saw that tasksel has 4 dependencies as follows:

  1. debhelper (>= 9)
  2. dpkg-dev (>= 1.9.0)
  3. gettext
  4. po-debconf

Remedy That Worked:

  • I checked my Ubuntu installation using sudo apt list --installed debhelper and saw that I do not have debhelper installed. The other 3 dependencies were installed and the correct minimum versions.
  • I installed debhelper using sudo apt install debhelper.
  • I reran sudo tasksel and selected ubuntu-desktop.
  • This time, tasksel ran without error.
  • I want to point out I have attempted to recreate this error on a reverted VM, but I cannot! I don't know how I bungled the tasksel installation to fail into "apt-get failed (100)"
    – DrTinyCat
    Feb 25, 2021 at 20:22

1 Answer 1


I was also stuck apt-get error following the steps you used to reproduce error. But then I was looking at the guide for install KDE GUI and directly used this command: sudo tasksel install ubuntu-desktop

and it was able to install what's needed. I'm using ubuntu Ubuntu 20.04.1 LTS as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .