0

I have issue with this one particular Windows 10 client unable to connect to any SMB share.

Environment:

  • Server: Windows Server 2019
  • Client: Windows 10 Pro Workstation 20H2
  • Internal LAN
  • No domain just LAN in my home.

Server side

I have created SMB file share in the server manager, and running fine.

PS C:\Users\Administrator> Get-SmbSession

SessionId   ClientComputerName ClientUserName   NumOpens
---------   ------------------ --------------   --------
51539607553 192.168.0.209      PVE-SERVER\share 1

Tested with another virtual machine I can easily connect to file share, which means no issue with SMB server.

The shared folder created with user access and deny guest access. The SMB version is 3.1.1

Client side

  • Removed antivirus, firewall and disabled windows firewall.
  • Unable to connect by mapping network drive.
  • Can see the servers in network, means the network discovery is enabled.
  • Unable to connect to server by double click in the network browser.

Tried with New-SmbMapping in PowerShell gives me error cannot find network path.

Tried with net use to server with error 53. I have replaced with IP address but still getting the same error.

Tried to restart lannman.

Checked in system event for SMBClient, found error with event ID 30800, which is The server name cannot be resolved. However, I have no issue to nslookup or ping server, only took 1ms to resolve.

It looks like something wrong with DNS but I can remote to server by host name and access internet. Also checked hosts file which has no changes.

I'm running out of options here. Any help is appreciated.

2
  • 1
    Do you have WINS set up? It's probably easier to start using WINS than debug why NetBIOS Name Service isn't working. – Spiff Mar 1 at 6:42
  • 1
    Before the issue happened, did you do any modifications? Or install any updates? May also check SMB sever log on SMB server to see if there is something related. – Candy Mar 1 at 8:48
0

Thanks for the suggestions, I tried to check on Server log, the client never reached. So I have to reset my Windows 10 and it get resolved. Therefore, this must be some software changed my network settings and make this happen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.