0

I am on Windows 10 ( 32-bits system) on an oldish Intel 2- Core 14-2120 3.30 GHZ 32-bits CPU, 4 GB physical memory . I want to virtualize a 2nd OS ( Windows 10) in order to switch between the two OS without having to reboot each time. Unfortunately all the Virtualization softwares I have looked into, are designed for 64-bits. I tried a few of them and I invariably get a message that I cannot install because a 64-bits platform is required.

I have been able to install only an older VMware app. ( v. 5 or so) It did go in. and I was able to create a VM box by following the instructions. However I hit a brick wall: when I try to install the CD from the optical drive, I do get the Windows Logo on the VB screen, but it stops there and I cannot install the virtual Windows 10. Why? How can I finalize the 3nd OS installation?

Thanks

Ittiandro

5
  • 1
    “Unfortunately all the Virtualization softwares I have looked into, are designed for 64-bits.” - This is absolutely false. VirtualBox absolutely has a 32-bit version. Now granted the performance is absolutely horrible but it absolutely is possible. I did it over 15 years ago on an old 32-bit Visa laptop I had.
    – Ramhound
    Feb 28, 2021 at 23:08
  • Maybe Win10 won't work on that VMware v5...
    – gregg
    Feb 28, 2021 at 23:22
  • 1
    I have no idea what “VMWare 5” refers to exactly. Cause the other indicates a “VB” logo
    – Ramhound
    Feb 28, 2021 at 23:44
  • I remember virtualization software in the 16 bit days...
    – Keltari
    Mar 1, 2021 at 2:39
  • Tks VMWare 5 stands for version 5. Ï'd found it listed among the older version in their site.Secondly, I spent hours looking for and trying versions supposedly unning on 32-bits. Even when they say 32-bits, I get the same message that I cannot install it because it only goes on 64-bits. Confusing, isn't it? If you can tell me how I can get yours that worked on 32-bits, please let me know. Thanks Ittiandro
    – Ittiandro
    Mar 2, 2021 at 19:18

3 Answers 3

3

Your 32-bit system only allows 3.5 GB at most. Windows 10 needs 2 GB to install and run leaving little or nothing for the host system.

Also VMware Versions that are very old normally supported operating systems (Host and Guest) up to the year of the VMware Version. That is very likely the error stopping you. V5 did not know about Windows 7 and up and trying to run them easily results in errors.

I did find an old email from participation in the VMware beta program. V5 dates back to 2005 - 10 years before Windows 10. So I think V5 is hopeless for today's operating systems.

Your system is not really adequate for virtualizing today's modern systems.

You would need to upgrade the host machine. You may be able to change to Windows 10 64-bit and add some memory, but that is a big upgrade itself. Also your existing HDD is likely a 5,400 rpm drive which is another constraint in this machine.

Note: For VMware versions back that far (V5) (I go back to Version 1), it was feasible to virtualize Windows 95 and 98 and early versions of Linux, but not the very large systems of today.

2
  • A 32 bit system capable of running Windows 10 is NOT constrained to 3.5 (or even 4 gigs) of RAM. en.wikipedia.org/wiki/Physical_Address_Extension - Of-course, the i3-2120 is a 64 bit CPU and includes VT-X - so it should be possible to run full virtualization on the bare metal - albeit not well - ark.intel.com/content/www/us/en/ark/products/53426/…
    – davidgo
    Mar 1, 2021 at 0:01
  • 1
    The host system is 32-bit (and old) and that would constrain the host and the guest to work all within 3.5 GB . So this is a significant challenge unless the OP upgrades the computer (64-bit OS and memory)
    – John
    Mar 1, 2021 at 0:13
1

If you look in the bios and it says that virtualization is enabled then yes, your device supports virtualization. You can then download virtualbox 5.1 at most. (Virtualbox 6 does not support 32-bit)

0

It is possible as clearly virtualization existed before 64-bit systems. There are many virtualization software and several run on 32-bit systems. There are least three that I have personally used on a 32-bit system. Of couse, since most modern computers are 64-bits, newest versions of virtualization software are designed for 64-bits systems as you noted. You may find older versions of Virtual Box, for example, on an older Linix distribution.

Remember that virtualization requires a substantial amount of resources, so a 32-bit host systems is going to be very limited. Also newer processors have special facilities to make virtualization more efficient, so even if you have the resources, there will be a greater performance impact for the guest operating system than when running on a modern 64-bit CPU.

The one major limitation of common virtualization technologies is that they do not instructions. Without going into technical details, the main consequence is that you cannot run a 64-bit guest system on a 32-bit host and that is the most likely reason for not being able to install an OS. This also happens if the OS assumes a certain level of instruction set as minimal requirement that is not satisfied by the host processor.

4
  • Thanks to you all. I kind of suspected that my system is too old
    – Ittiandro
    Mar 2, 2021 at 1:00
  • You're welcome. Specifically, if your system is too old to run Windows 10, it won't run on the system as guest or host. Otherwise, I've used virtual machines long before the system you are running on exited! Virtualization is not emulation in that it has to support the instructions your guest requires.
    – Itai
    Mar 2, 2021 at 3:42
  • Thanks again. Windows 10 runs pretty well on my oldie, though. I don't disloke experimenting . If you tell me the exact version of yours that ran 0n 32-bits and where I can get it, please let me know. I like experimenting. I always learn new thinks after hitting brick walls. It is a bit like science: some of the discoveries arise out of unsuccessful experiments, leading into new territories.. Thanks Ittiandro
    – Ittiandro
    Mar 2, 2021 at 19:28
  • It's been a very long time and I was not keeping track of versions but I found that I purchased Parallels Desktop 4 which ran for years on a 32-bit system of mine. VirtualBox also worked but I don't know at which version I switched to 64-bits, so you want want to lookup what was the last 32-bit version.
    – Itai
    Mar 2, 2021 at 19:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.