7

I have been impressed with the improvements in search introduced in Outlook 2010. Unfortunately, in the last week search has stopped working for me.

I have tried all the obvious repair tasks such as repairing office, disabling all add-ins, rebuilding the index, compacting the PST, but no luck.

It appears that 'mssphtb.dll' (Used by search) keeps crashing and as a result Outlook Disables it. I have tried re-enabling it, but Outlook immediately disables it again.

I have had a look in the Windows Event Log as well, but Outlook does not appear to log any errors that occur when loading add-ins.

A lot of people appear to have the same problem, but no fixes so far.

I am considering installing Xobni, but I prefer to make Outlook work the way it is supposed to and not rely on 3rd party applications.

7

I am answering my own question here. Although the Add-in is still marked as disabled I think the problem of not being able to search has been fixed.

I followed the following Procedure:

  1. Position cursor in search bar
  2. In the ribbon click Search Tools / Search Options
  3. Click the 'Indexing Options' button
  4. Remove the Outlook inboxe(es) from the list of Included Locations
  5. Close the Indexing Options window and reopen it
  6. Add the Outlook inbox(es) back to the list of Included Locations

The index for Outlook will now be rebuilt.

I don't think this procedure is the same as the 'Rebuild Index' button as that rebuilds all indexes.

  • I have the same problem (the add-in is showing disabled too). For me, the above fails at "Click the 'Indexing Options' button"... which does absolutely nothing (presumably a sign of deeper brokenness). – timday Feb 13 '12 at 13:07
  • +1 this works. However note that if you try to access the same through the control panel , the outlook options are greyed out – DannyBoi Sep 27 '16 at 2:13
2

I had the similar problem.

My solution.

  1. Mark / Highlight the checkbox Indexing service in "Programs and Features" "Turn Windows features on or off"

  2. Repair Office. How? Programs and features, right click on Microsoft Office 2010 and choose "change". A window will pop up and choose for "repair".

  3. After this, restart PC and indexing will start working. It can take a while, but you can already see, that you can search your emails and that you get all results you want.

1

This behavior is by design. Windows Desktop Search installs a MAPI Protocol Handler. This handler is responsible for indexing data in earlier versions of Outlook. Outlook 2010 now includes some of that indexing and search functionality in the program. Because the new functionality is built into Outlook 2010, the original Windows Search indexing components and addin are disabled in Outlook 2010, but not removed. This ensures that earlier Outlook versions can be indexed correctly if Outlook 2010 is uninstalled.

1

I had the same problem regarding Outlook search and neither rebuilding index nor deleting any temp folder helped. What helped me was:

  • Control Panel> Programs> Programs and Features> Turn Windows Features on or off
  • Uncheck "Windows Search" in Windows Features
  • Restart computer
  • Check "Windows Search" in Windows Features (Outlook takes a while processing the re-indexing)
  • @HackToHell thanks for updating back my comment and removing stupid update which mentioned my name moreover with a misspell. – Ani Feb 3 '15 at 16:45
  • lol, just following community guidelines. – HackToHell Feb 3 '15 at 16:54
0

I tried Office Repair and that didn't work. However disabling Outlook under 'Indexing Options', performing a search without the indexing, and then enabling it again worked wonders. It came back straight away.

0
  1. Position cursor in search bar
  2. In the ribbon click Search Tools / Search Options
  3. Click the 'Indexing Options' button
  4. Go to Advanced tab and click on Index Setting
  5. Click on Restore Defaults options and click on ok
  6. Close outlook and reopen outlook

Above solution works for me when my outlook 2010 search stopped working

0

I went into 'Indexing Options' then 'Modify' and removed 'Outlook' altogether. Due to all the profiles, if I expanded 'Outlook' I saw many accounts and PST files and thought first I would just uncheck the ones I don't need to search... that didn't help.

Surprisingly, just removing Outlook doing a search was quick and thorough. I also did a search in 'All Mail Items' to see how well the old archive files and other accounts I do use were searched - works like a charm right now.

For me, removing Outlook from Indexing Locations left it removed.

0

I am facing this problem in Outlook 2010 whenever PST gets heavier.

Keep your indexing tab (indexing status) open along with the Outlook icon. It will start indexing more quickly. Your Internet speed should be good.

protected by Community Nov 9 '17 at 12:21

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.