I kind of like ripping my audiobook CDs to MP3 using Windows Media Player because it's free, easy, and comes with Windows. I really like how, when a CD is done being ripped, it can (in theory) auto-eject the CD so I can quickly put in the next audiobook CD. However, this auto-eject never works because of this annoying error:

enter image description here

I have tried all the steps in this article (titled How to disable the "Windows Media Player cannot download media information..." pop-up after ripping a CD without enabling network connectivity.) and it doesn't work. And I have tried this on other PCs as well.

So then I click OK and it finally ejects. This is so annoying to have to do EVERY TIME. I have read several tips/guides on how to avoid this but none of them work, including the link mentioned at the top of this post. There must be a registry tweak or something to prevent this from happening. I have unchecked everything in the Privacy and Network tabs, plus I tried the reg hacks mentioned in the link.

I'm using Windows 10. Version doesn't matter, this happens on every Win10 version.

  • You might try a free third-party tool, such as open-source fre:ac . See alternativeto.net/software/express-rip for other alternatives. Mar 3, 2021 at 5:01
  • DrMoishe, I'm liking fre:ac, but how can I make it auto-rip when a CD is inserted, and auto-eject upon completion? These are 2 great features in WMP. Mar 3, 2021 at 17:03
  • Not sure if it's fully impolemented, but see freac.org/latest-news-mainmenu-2/14?start=12 Mar 3, 2021 at 18:02
  • Yeah, found both checkboxes, but auto-rip doesn't work. Only auto-eject works. I'm going back to WMP and using an auto-button clicker to click that annoying popup for me. Mar 4, 2021 at 0:58


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.