I recently installed Windows 7 Ultimate on my PC, and imported my music collection into WMP11 only to find that around 1/3 of my 3500-odd collection is identified as "Unknown Artist" "Unknown Album".

All the files are tagged correctly (using MusicBrainz Picard), other media players see them fine (e.g. Rhythmbox on linux), and WMP will play them without problems. I've tried installing K-lite and Shark007 codec packs (I uninstalled K-lite before installing the other one) to no avail, and I've tried deleting WMP's cache and rebuilding the library several times. Finally, I've double-checked the permissions on the Music folder. The unrecognised songs are of different file-types and are not all from the same album.

Does anyone have any ideas on how to proceed? I'm aware of a large number of more competent media players, but I'd like to get WMP into a working state at least.

Thanks in advance for your help.

  • Open a few of the "not working" files in Mp3tag and see what version of ID3 they're using.
    – Hello71
    Jul 13, 2010 at 14:46
  • It's an intelligent media player. When the artist becomes famous, it'll change to the normal name. :P | Also: Consider using Foobar2000. :)
    – Apache
    Jul 13, 2010 at 20:52

1 Answer 1


There are two sets of ID3 tags available in mp3s. ID3v1 and ID3v2 - see Wikipedia - and different versions of the ID3v2 tags.

I can't remember off hand which set Windows Media Player reads, but if MusicBrainz has used one standard and WMP is reading another then there'd effectively be no information for it to display.

WinAmp has a dialog that shows the two sets of tags and allows you to copy the information from one set to another so you could check that out. There are other ID3 tag editors available.

  • ID3v1 is very obsolete and rarely, if ever, used these days. No sane programmer - especially not Microsoft - would release a music player without ID3v2 support. That said, there are several versions of ID3v2 - some sources say WMP 11 supports ID3v2.4, others say it only works with v2.3... There also might be problems with usage of UTF-16 and UTF-8.
    – user1686
    Jul 13, 2010 at 20:01
  • @grawity good point. I'll update the answer.
    – ChrisF
    Jul 13, 2010 at 20:25
  • I used ID3-TagIT (as suggested by this technet Article), and converted all ID3v2.4 to ID3v2.3 and now WMP is reading all files correctly. Thanks for your help!
    – supervacuo
    Jul 17, 2010 at 18:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.