5

I have a problem with my newly installed ATI driver so my Fedora 12 boots to a frozen graphic mode display.

I need to force it to boot to text mode interface to start adjusting my X configuration. What to do?

This is a new Fedora 12 installation without any change to GRUB etc.

Thanks!

8

When you first start your computer, the GRUB screen (where you choose your Operating System) appears. Select the Fedora that you want to boot into, but press the a key instead of pressing Enter.

You will see a line somewhat like the following:

kernel /vmlinuz-2.6.9-1.667 ro root=LABEL=/ acpi=on rhgb quiet

Add the number of your runlevel to the end of that line, and then press Enter. For example, to boot into text-only mode, the line would look like:

kernel /vmlinuz-2.6.9-1.667 ro root=LABEL=/ acpi=on rhgb quiet 3

You will then boot into the new runlevel this time only.

More about runlevels: http://www.fedorafaq.org/basics/#runlevel

  • This worked for me in Fedora 22, though I had to hit 'e' instead of 'a' and scroll down to find the "quiet" parameter. I added a '3' after the quiet, pressed Ctrl-X, and it booted into text mode. Thanks! – Steve HHH Feb 12 '16 at 7:17
3

Hold down Ctrl when booting to show the GRUB menu. Then select the kernel you care about, hit A, remove rhgb if it shows on the line, then go to the end and type Space3Enter.

  • I would accept your answer too but I can accept only one answer. Also I can't give you +1 because I am too poor. Thanks very much Mr rich :) – mmonem Jul 13 '10 at 15:25
  • 1
    @mmonem - Here, +1 from me then ;) – BloodPhilia Jul 13 '10 at 16:20
0

Since this thread is the top most on Goole.com when searching for How to boot Fedora to text mode I add this guidance for newer versions of Fedora.

To boot into text mode in never versions of Fedora 16+ using GRUB2 the steps are slightly differren:

  1. When you first start your computer, the GRUB screen (where you choose your Operating System) appears
  2. Select the Fedora that you want to boot into, and press the e key instead of pressing Enter to edit selected item
  3. Scroll down to find the parameter quiet parameter and add white space and number three just after the quiet parameter, ie quiet 3
  4. Press Ctrl+X to start
  5. Fedora will reboot into the text mode

Tested on Fedora 20, 22, 29

-1

On newer versions, pressing A won't work any more - hit now "E" to enter edit mode. A multi-line configuration will appear, but there you will find again those same entries "rhgb" and "quiet", just remove them and put a 3 instead.

Then pressing F10 will take you to the (now usefully verbose) boot process, landing in a (text) login prompt. Done.

(Tested with Fedora 20).

  • The question, however, is about Fedora 12, as it says three times over. Fedora didn't switch to GRUB2, with the different keyboard commands, until Fedora 16. – JdeBP Feb 14 '14 at 4:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.