I'm using SVN version 1.6.6 (r40053) via the command-line in Ubuntu 10.04 and connecting to a remote repository over HTTP that is in the local network. For a while, it worked fine, but has recently become very slow for any operation that requires communication with the repository, however it does eventually work after several minutes (~3m for svn up). Looking at Wireshark, it appears to be taking a full minute between the HTTP auth denied and the subsequent request containing credentials.

The issue is local to my machine because other coworkers running Ubuntu are not having the issue and I've tried using my credentials from another machine and it was very fast.

I tried deleting the .subversion folder in my home directory and checking everything out fresh, but it didn't help.

Update: I think it's auth related. When I check out SVN repositories off of the Internet over HTTP (from Google Code, for example), everything is very fast until I do something that requires a password. Before prompting for the password for the first time, it stalls for at least a minute.

Update 2: I set the neon-debug-mask in the SVN settings (in /etc/subversion/servers under [Global]) to 138 and it seems to spending a lot of time on 'auth: Trying Basic challenge...'

  • Are you using SVN+SSH? – yalestar Jul 13 '10 at 17:25
  • No, it is over HTTP in all cases (on my computer and on the ones where it is fast). – Sydius Jul 13 '10 at 17:26
  • 1
    Try checking the HDD health with smartmontools. Maybe there's an issue there. – Daenyth Jul 13 '10 at 19:31
  • No HDD problems detected. – Sydius Jul 14 '10 at 23:55
  • For slow access over https see also serverfault.com/questions/716845/… – anre Jun 30 '17 at 10:32

In my case, it took a lot of time in the phase "Doing DNS lookup on XXX...", where XXX is my HTTP proxy configured at ~/.subversion/servers. In this case, the repository was listed in the "HTTP proxy exceptions", but Subversion did the DNS lookup anyway. It works, but with a very long delay (about 2 mins). The solution was just replace the XXX by the IP addresss.

  • I had a similar problem, instead of use IP directly, I put the hostname on the /etc/hosts file of the apache proxy server (it was the cause of the slowness). – BrunoJCM Dec 30 '13 at 19:00

Turns out rebooting fixed it--something I never think to try with a Linux machine. Logging out probably would have as well (I am only in the habit of locking it).

I am using Likewise Open to connect my machine to a Windows domain; I think that must have had something to do with it. I hadn't rebooted in months. Hopefully this helps someone else out there who runs into this problem.

  • 2
    What is this rebooting thing you troll about? Since XP I've had machines with regular 40+ days uptime. – ta.speot.is Jun 21 '11 at 12:25

I added

--username *my_username* 

after the svn command and it is now instant.


I had something sort of similar once, but it turned out to be IPV6 related.

Are you experiencing sloweness elsewhere, like accessing an internet site for the first time?

If so, you might want to check that your ubuntu isn't set up for IPV6.

  • I haven't noticed it behaving slowly with anything else. Web sites, including ones I have never visited before, load fine and quickly. – Sydius Jul 13 '10 at 22:14
  • Ok, one item almost crossed out then :-) Take a quick check if there's any svn-server related stuff in your /etc/hosts :-) – tovare Jul 13 '10 at 22:38
  • Nope, nothing there. – Sydius Jul 14 '10 at 16:00
  • ok, I suggest adding the svn server to the hosts file with full IP :) I'm still betting it's related to something not finding something, since it takes so long on the authentication. Also try uname -n on your machine, then try nslookup <the host uname -n reported> – tovare Jul 14 '10 at 19:45
  • On second though, adding to the hosts file won't help. But nslookup uname -n might bring diagnostics one step further if there's a long delay. Might be worth a shot if you're stuck. – tovare Jul 14 '10 at 20:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.