0

I was trying to setup a lab environment for Vulnhub box. I ran both Kali VM and Kioptrix level 1 VM on VMWare Workstation Player. I heard that I should set the network adaptor of both VMs using NAT or host only to be safe. I could set Kali's network setting to NAT/host only without any problem.

The weird thing is, although I have set the mode to NAT/hostonly on Kioptrix VM before playing the VM, the setting will always automatically switch back to Bridged(Automatic) when the VM is launching.

When Kioptrix is running, I can manually set it back to NAT/hostonly and reconnect, but Kali still cannot detect it with the same setting. So I guess it has something to do with the automatic mode switch.

Other observation:

  • Kali can only detect Kioptrix when two VMs both under bridged mode.
  • I tested with Kioptrix Level 1 and Kioptrix Level 2 VMs, both have the same issue
  • I can setup metaexploitable VM properly, and Kali can detect it.

Can anyone explain to me what could cause the automatic mode switch? Thank you very much

2
  • 1
    Since you say it happens only to this one VM: did you create that VM yourself, or did you download it from somewhere else? Are you sure that the network setting changes back to Bridged when the VM is powering-on and not when the VM becomes powered-off? If the change occurs when the VM is powered off, I'd suspect that the VM is configured to automatically revert to a snapshot. (VMware Player does not offer UI for this; you would need to inspect the .vmx file. If you make any other configuration changes to the VM, are they preserved when the VM is powered off?)
    – jamesdlin
    Mar 9, 2021 at 8:12
  • @jamesdlin thank you for your suggestion. I tried to change other options such as increasing its memory. Those changes are persistent and will not be reset upon power on/off. Only the network mode gets switched back to bridged. I also added some files to that machine, and they are still exist after rebooting.
    – NoobieG
    Mar 10, 2021 at 4:04

1 Answer 1

0

I am in VMware Workstation (networking very similar to Player) and I am in a Kali 2021.1 machine here (I have about a dozen machines in this computer).

Host Only is disconnected from the outside world and is more for isolated testing. It is not used for general work where Internet is required.

NAT / Bridged both allow you to use Internet freely. Bridged networking uses DHCP from your router outside your Host machine. NAT networking use VMware's NAT engine and provides DHCP to the guest machines in a different subnet than the host.

You need to be aware of which networking you are using as both work. Bridged networking is on the same subnet as your router and this can facilitate file sharing across machines.

NAT / Bridged is not a "safety" issue any more than a Host machine (which is likely where you have your email and stuff). Host Only is "safe" only because it is very restricted. It is not helpful for general work.

I do not use and cannot say about Kioptrix, but both Kali and Ubuntu (and all Windows) work fine with either NAT or Bridged.

Kali can only detect Kioptrix when two VMs both under bridged mode.

That is likely due to Kiptrix more that Kali. I can share files Kali to Host and I can certainly connect to Ubuntu and this is with Kali and Ubuntu using NAT networking on my Windows 10 host computer. So it appears the issue you are having is due to Kioptrix or a compatibility issue between Kali and Kioptrix.

I can setup metaexploitable VM properly, and Kali can detect it.

That seems normal.

Can anyone explain to me what could cause the automatic mode switch?

I do not see this at all - multiple VM's and 3 running here all simultaneously. No mode switches at all.

See if you have in your Programs, VMware, Virtual Network Editor. Launch the Network Editor Go to the NAT setup and Reset NAT. This will change your NAT Subnet and requires you to restart the computer. At this time, it would be useful to Repair VMware Player by reinstalling it (no impact on machines).

Now let's deal with your machines. Turn off Kioptrix and leave it off. Update Kali and then shut it down.

Now restart your host system, start VMware Player and launch just Kali. It should launch properly and not change Modes.

Note: The Kioptrix web page says DHCP is enabled within Kioptrix and that IP address is automatic. You probably want to turn that OFF.

This should provide some good information to get you started. I have been using VMware Workstation since VMware Version 1 on Windows NT 4 Workstation and all versions up to V 16 on Windows 10. So I am familiar with using NAT Networking on Laptops (not always connected to the outside world) and Bridged Networking on my Desktop computers (always connected).

3
  • Thank you for the very detailed explanation. I also think it is the problem of Kioptrix VM since the mode switch issue does not happen to my Kali and other VMs. I just tried to restart my host and the problem still exist. I guess the only thing I can do for now is to run both of them with bridged mode so that I can continue my lab.
    – NoobieG
    Mar 9, 2021 at 2:51
  • Another thing to try is to establish Kioptrix in Bridged Mode.. Leave it that way and see if Kali starts and stops in NAT without changing modes. If so, that does narrow down the issue to Kioptrix and not VMware. Also the versions I see for Kioptrix (quick look) are several years old.
    – John
    Mar 9, 2021 at 3:00
  • I have downloaded and set up the Kioptrix VMDK file from Vulnhub and sent through the settings. Default Networking was Bridged. I left it like that and nothing at al was reset (the other NAT machines). So everything I posted in my answer is all true and the issue you have is Kioptrix. Just accept the Kioptrix default and use as Bridged. All works. Hopefully you will acknowledge my answer.
    – John
    Mar 9, 2021 at 21:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .