0

One of the programs I used, apparently, set up file encryption on my PC. First, I noticed the "Encrypting File System" pop up asking to backup encryption certificate and key, then once I started looking why it would pop up in the first place, I found a certificate present in the user certificate storage with the purpose specified as "Encrypting file system" and "Valid From" a few minutes ago.

Running cipher /u /n gave me a list of encrypted files, which allowed me to (hopefully) identify the responsible program and remove it, unfortunately, for some reason it enabled encryption on whole bunch of files that are not related to that program and have paths that start with C:\Program Files\WindowsApps and %USERPROFILE%\AppData\Local\Packages (Windows Store apps, I presume).

I have access to the files, can see their contents, but for some reason I can't seem to remove encryption from them:

C:\Users\username\AppData\Local\Packages\Microsoft.FlightSimulator_xxxxxxxxxxxxx\Settings>cipher /d settings.dat

 Decrypting files in C:\Users\username\AppData\Local\Packages\Microsoft.FlightSimulator_xxxxxxxxxxxxx\Settings\

settings.dat        [ERR]
settings.dat: The parameter is incorrect.

0 file(s) [or directorie(s)] within 1 directorie(s) were decrypted.

It fails if I run it as Administrator, and even if I run it as SYSTEM with PsExec. Any idea how to decrypt those so I could safely remove the encryption certificate?

Update 1: The "Encrypt contents" checkbox is not set on a folder: Folder settings screenshot

It is set on individual files, but trying to remove it produces the same error as cipher /d produced:

Error Applying Attributes

I am the owner of the files:

file ownership

11
  • Can you provide screenshots of all the relevant Windows that indicates the ACL and permissions for the folder in question? I assume you have tried to just uncheck the checkbox in the properties for the folder?
    – Ramhound
    Mar 20 at 13:29
  • @Ramhound, added more details in the post. The permissions on file are inherited from the parent folder, I set myself as an owner of all files in questions when initially failed to remove encryption.
    – n0rd
    Mar 20 at 16:40
  • The reason you are having a problem is due to the fact you are dealing with DRM. Why are you masking the folder name? It's not unique to your system.
    – Ramhound
    Mar 20 at 16:43
  • I am not a Windows person, but I am confused as to what NTFS has to do with individual file encryption. To my knowledge NTFS is a file system type and if individual files are being encrypted, that has nothing to do with the file system: The same issue would appear if the file system was not NTFS. Mar 20 at 16:47
  • 1
    @n0rd - Did you install Microsoft Flight Simulator yesterday? Because I found a thread that literally confirms this is normal and is protecting the MSFS files. It seems we don’t have all the necessary information required to answer your question
    – Ramhound
    Mar 20 at 17:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.