I'm on Windows 10 Pro 10.0.21337 (windows insider program) and installed WSL with Ubuntu and Windows Terminal. After a firmware update the ubuntu bash wouldn't start anymore. In a cmd.exe the response was:

The operation timed out because a response was not received from the virtual machine or container.

I found this message in a few pages on the www but they were mostly related to docker containers.

4 Answers 4


A faster solution than a full PC restart is to run:

wsl --shutdown

...which will restart just the WSL service.

  • 2
    Yes, this works perfectly. Commented Sep 6, 2021 at 19:07
  • 2
    This also solved my timeout issues that appeared after a Windows 11 upgrade. Commented Oct 4, 2021 at 13:57
  • This does not work for me.. but I've got a long running process that is using just over a third of the CPU which makes it seem like WSL won't initialize if the system is busy enough.
    – Michael
    Commented Aug 12, 2023 at 21:28

This question is a bit different in terms of the symptoms but its solution solved this problem: A full reboot of Windows10, by opening Windows > Start Menu > Power > Restart while holding the shift key.


After having failed trying wsl --install and wsl --install -d ubuntu, I got the list of available distro with wsl --list --online and finally used wsl --install -d Ubuntu notice Ubuntu is Capitalized and this worked.


I was able to solve the issue by performing the following steps:

  1. Uninstall WSL2

  2. Enable Virtual Machine Platform:

    Open PowerShell as Administrator and run:
    dism.exe /online /enable-feature /featurename:VirtualMachinePlatform /all /norestart

  3. Enable Hyper-V:

    • Go to Windows settings and search for Turn windows feature on / off
    • Check/select Windows Hypervisor Platform and Windows Machine Platform
  4. Restart the machine to implement the changes.

  5. Download the following Linux kernel update package and install


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .