I seem to be the only one over the planet to get this problem, as I spent 1,5 hours to find a solution and I couldn't even find a question...

One of my Sandisk SD Card has a strange behaviour. It's used in my Nikon camera. It works there flawlessly.

However when I insert it to a SD Card reader (tried three computers with different reader manufacturers) the drive letter disappears from Windows Explorer. I then look for it the Drive manager: it's recognized (size and name) but with no drive letter.

So now I try to assign a drive letter, I click... and I get the following error message: "The specified file cannot be found" (sorry , translated from french). Same on the three Windows computers.

SD card recognized without drive letter

Using Recuva I could get the files back from the card, no problem. It's just a problem of assigning a drive letter I guess.

Any clue on what's going on? I may be an experienced Windows power user, but that one got me stuck... Thank you.

  • This isn’t a unique problem. Have you tried any of these solutions?
    – Ramhound
    Mar 23, 2021 at 3:04
  • This might also be a solution
    – Ramhound
    Mar 23, 2021 at 3:10
  • Oh, man, @Ramhound, you are right, I'm not alone! Honestly, I searched everything, but it looks like the french message did not translate in what I was looking for... Unfortunately, all these solutions have already been tried. I can use my SD card on the camera and on Ubuntu, it's just Windows having trouble. I gave up and bought a new one. I'll keep this one for Ubuntu boot disk :)
    – Ninj
    Mar 24, 2021 at 1:00
  • So you have reformatted the card?
    – Ramhound
    Mar 24, 2021 at 1:24


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Browse other questions tagged or ask your own question.