1

Prerequisite:

  • HostPC(Windows) as client

  • LinuxBoard(yocto linux) as server

  • LinuxBoard eth0 already setting static IP from the start

  • SSH connection via ethernet cable

  • ssh_config on HostPC (C:\ProgramData\ssh\ssh_config)

    Host *
      ServerAliveInterval 5
      ServerAliveCountMax 20
    
  • ssh_config on LinuxBoard is default

I have problem on re login after rebooting my LinuxBoard. To reproduce the problem:

  1. From HostPC(Windows) connect SSH to LinuxBoard(yocto linux) At first connection is success. Continue with login.
  2. Then after login, reboot LinuxBoard by run reboot In this phase, ssh is disconnected.
  3. I re login by run this command
C:\Users\evan-hutomo>ssh -vvv root@192.168.1.xxx
OpenSSH_for_Windows_7.7p1, LibreSSL 2.6.5
debug3: Failed to open file:C:/Users/evan-hutomo/.ssh/config error:2
debug1: Reading configuration data __PROGRAMDATA__\\ssh/ssh_config
debug1: __PROGRAMDATA__\\ssh/ssh_config line 1: Applying options for *
debug2: resolve_canonicalize: hostname 192.168.1.xxx is address
debug2: ssh_connect_direct: needpriv 0
debug1: Connecting to 192.168.1.xxx [192.168.1.xxx] port 22.
debug3: finish_connect - ERROR: async io completed with error: 10060, io:0000020A0B5516A0
debug1: connect to address 192.168.1.xxx port 22: Connection timed out
ssh: connect to host 192.168.1.xxx port 22: Connection timed out

I did not enough with ssh behavior, however I try to reconnect to LinuxBoard and sometimes I can connect, but mostly I cannot connect to LinuxBoard. My goal here is to make Host able to re login to Server after rebooting. I tried with several similar commands here but still gave me same phenomenon. reboot, shutdown -r, systemctl reboot I already search the result on SO, and everything but still did not solve my problem.

Could somebody give me insight to solve this phenomenon?

Thank you

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.