2

I have two monitors, one landscape (set as main display) and one portrait. I prefer to have the notification area on my left (portrait) monitor, so I drag the taskbar over to it to achieve that.

For a long time this state was saved by Windows over reboots, and the only thing that reset it was an Nvidia driver update. However recently it started resetting on every reboot/startup.

OS version: Windows 10 Pro, 10.0.19041

If it was working:

  • The portrait display (extended display) should have the main task bar.
  • The landscape display (main display) should not have the main task bar.

Update: When Windows starts up and is at the login screen, I hear the device connection sound you hear when you plug in a device. The screen flashes before coming back on. I've noticed after many restarts that the only time the taskbar position remains on the portrait display is when this sound/flash does NOT happen.

So far I've been unable to determine what causes the screen to flash/the connection sound to be made. Both monitors are on during any boot/restart process, and neither appear to be asleep in any way as the time from boot to login is quite short.

14
  • Which display is Primary? – Tetsujin Mar 29 at 14:57
  • 1
    If you switch the video cables and/or ports on the GPU (I assume they are the same) does the behavior change? What is happening is a sign the display is not enabled at the time Windows goes to assign displays. This is probably happening well before you even see the Windows logon. – Ramhound Mar 29 at 15:02
  • @Ramhound that's interesting, it is completely possible I'm leaving it at Windows login long enough that my extended display is turning off. I'll try that. – Jeff Dalley Mar 29 at 15:09
  • Do you have any apps that modify Windows look (ex: Stardock)? Maybe that is resetting. Analyze keys here on fresh boot compared to AFTER you move taskbar: HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer (Group Policy: User Configuration\ Administrative Templates\ Start Menu and taskbar\Lock all taskbar settings). SW might be changing it here, sysinternals procmon can help isolate WHAT is changing that registry thus causing – gregg Mar 29 at 15:16
  • @gregg I don't believe so. I'm using Power Toys (Fancy Zones), not sure if it would touch anything Taskbar related. The only key at that location after a boot and moving the Taskbar is: NoDriveTypeAutoRun. – Jeff Dalley Mar 29 at 17:26
1
+50

The two facts, that you hear the device connection sound and that the monitors are connected via DisplayPort, is a big hint.

DisplayPort ports under Windows are implemented differently than VGA and DVI ports, in that when they enter the sleep state Windows treats them as if they were removed, even displacing their displayed windows to other monitors. When the monitor wakes up, Windows treats it as a new device being discovered. This behavior might be the cause of your problems.

It seems like Windows, when starting, discovers the DisplayPort monitors at a later stage of the boot than before, therefore treating them as new monitors. Specifically, the taskbar is not installed on the monitor, since it is not available at that time.

I don't know what caused that change. It might be a change in Windows, or a new monitor driver (this is something that you may check).

If you don't find out what has changed, you will need to change your setup, perhaps defining the other monitor as primary, or finding out how to automate the moving of the taskbar upon boot to the secondary monitor (the free AutoHotkey may help here).

3
  • I believe this is exactly what the problem is. As for how to solve it - that's another matter. I'll dig in and if I come up with something I'll comment here. – Jeff Dalley Apr 9 at 16:32
  • If it comes down to blocking Windows from updating a driver, see this answer. – harrymc Apr 9 at 17:38
  • Just an update but I never actually figured out how to resolve this. I'm kind of living with it for the moment and hoping some combination of windows update or nvidia driver update fixes it. Unfortunately. – Jeff Dalley 19 hours ago
1

Are you using more than one Language within Windows?

Using mutltiple keyboard with [Shift]+[Alt] and it's keyboard settings have produced this error for me in the past.

Removing any other Keyboard layout than the native one did the trick for me.

Nothin special, but maybe this helps.

Cheers

2
  • I did have an extra language set in windows, which was partially attributed to the keyboard/desktop. I had the switcher turned off (and the hotkeys removed). So I'm not sure if removing it was the fix - or if it was something else I did. But this seems like a possible reason. – Jeff Dalley Apr 7 at 18:25
  • Update: this didn't solve it after all. Still trying to narrow it down. – Jeff Dalley Apr 8 at 2:07
0

Not exactly sure what you're asking, but I think what you want is for the Taskbar to remain on the same monitor after reboot and don't want the taskbar to be on any other monitor.

There is a settings that will allow you to make a monitor your main display.

  1. Start -> Settings (gear icon) -> System -> Display.
  2. Select the monitor you wish to make your main display. (The monitor you want the task bar to be on)
  3. On the bottom, in the "Mulitple displays" area, put a check mark in "Make this my main display" enter image description here

Next, need to change the task bar settings

  1. Start -> Settings -> Personalization -> Taskbar
  2. On the bottom, in the "Multiple displays" area, turn off "Show taskbar on all displays" enter image description here

That should do it.

0

I've also had taskbar related problems before. To mitigate that, I had to make a new user account - it worked. Try making a new user account and see if it's okay in the new account. If all's well, then move your files to it and delete your old account.

To make a new account, click Win+I. It should open Settings. Now go to Accounts

Settings

After that, go to Family & Other Users (from the sidebar)

Settings

Now, in the Other Users section, click Add someone else to this PC

Settings

If you have a second Microsoft account, log in using that. If not, then make a local account for now (You can log in using a Microsoft account later). To do that, click I don't have this person's sign-in info After that, click Add a user without a Microsoft account

Settings

Settings

After that, enter an username and password and proceed. You now have a second account. Log into that and see if the problem persists

1
  • I actually tried this as well - I'm on a completely new user profile. After transferring all my stuff over the problem persisted. Good idea though. – Jeff Dalley Apr 9 at 13:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.