My previous employer used MS Teams. I had logged in on chrome at one point. Recently I was asked to do an interview at a different company using Teams for video chat. When I clicked the link I was taken to a login page: enter image description here

I no longer have access to this account and I am unable to find any way of getting past this screen. I was able to go straight to the interview (no login required) using an incognito window, but I would prefer to not have to do that in the future as I believe it was causing webcam issues. I tried clearing the cache but to no avail. What should I do next?


  • I do not have desktop teams installed.
  • I have not signed into teams on this computer since October
  • I am unable to login (no longer have access to this account) and there is no button to log out
  • "I tried clearing the cache but to no avail." - What did you try exactly? Did you simply logout of the account within your browser or did you delete the cache files for Microsoft Teams itself? Please edit your question instead of submitting a comment – Ramhound Apr 2 at 12:52
  • It might be simpler to uninstall Teams and reinstall. – harrymc Apr 2 at 15:05
  • Clearing the cache does not clear cookies. Tried that yet? Keep in mind that you will be logged out from everything if you clear them. // Just to make sure: All of this is exclusively taking place in Google Chrome, right? No Teams desktop application involved? – Daniel B Apr 2 at 15:28

What you are describing seems to have a solution at the following link:


refer to the section "Issue: You are unable to create a new team in Microsoft Teams

If you are attempting to create a new team in Microsoft Teams, but cannot, check with your system administrator. Companies and organizations have the option to disallow individuals from creating new groups or teams. Reach out to your IT department for further assistance with the matter.

Hope this helps.

  • I believe the question asks about a different problem: not being able to follow link without signing in. – Máté Juhász Apr 2 at 13:30
  • this answer is much like many of the answers that google tried to give me when I looked there. Thank you for the attempt, but it does not answer the question :) – thepaulpage Apr 2 at 18:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.