1

The error "Faulting module name: MSVCR120.dll" is generated when the app WeatherLink 6.0.5 crashes.

The event log reports:

Faulting application name: WeatherLink 6.0.5.exe, version: 6.0.5.0, time stamp: 0x5b638b21 Faulting module name: MSVCR120.dll, version: 12.0.21005.1, time stamp: 0x524f7ce6 Exception code: 0xc0000409 Fault offset: 0x000a46a9 Faulting process id: 0xb80 Faulting application start time: 0x01d723c977fefac0 Faulting application path: C:\WeatherLink\WeatherLink 6.0.5.exe Faulting module path: C:\WINDOWS\SYSTEM32\MSVCR120.dll Report Id: 669196e7-c960-4b24-bb84-77414424aa21 Faulting package full name: Faulting package-relative application ID:

The PC is running 32 bit Windows 10 Pro Version 20H2 build 19042.906 4GB RAM Intel Atom D525 @1.8GHz System normally reports 1.5GB RAM in use. WeatherLink using 5.3MB normally.

I reinstalled WeatherLink and assured all Windows updates and optional updates installed. No change.

I then wiped the PC and installed Windows again and then WeatherLink. System seemed to work fine for some time but has now started failing again. It normally happens overnight . AV software is Microsoft Defender. The PC is connected to a 1500VA UPS and APC software is installed on the PC to manage the UPS. No other applications have been installed.

The app can be restarted and sometimes runs for a few days.

There are sometimes issues writing to files in the C:\WeatherLink folder which is the default install location for the app. App reports unable to write. The application hangs at that point but does not close and generate an error. The event does not appear in any log. The logged on user has Full Control of the folder and files.

Software vendor support reports "This error is with the "Visual C++, in Visual Studio" that we rely on." Suggests contacting a computer technician.

The system has Visual C++ 2008,2013 and 2015 Redistributable installed and the installs have been repaired following the complete Windows reinstall.

Vendor support indicates they have no connection to error and that it is solely Visual C++.

I have seen a number of posts reporting that MSVCR120.dll is missing and creating issues but not the same issue.

The application ran under Windows 7 for many years without issue. Vendor support says it runs under Windows 10

UPDATE

Today the system threw error “Cannot write to C:\weatherlink\download.log” The app remained open and clearing the error popup allowed the screen to refresh with latest data. The user is local admin and has full control of the Weatherlink folder and all files.

No error listed in Event Log for that event.

I had uninstalled Visual C++ 2008 and 2015 as suggested by @RAMHOUND but while looking for anything related to the write error above,Event Log entry I find Visual C++ 2015 has installed today. Could this be related to Windows Defender update? Definitions updated earlier today.

Around the same time, there is activity in System Log around Skype but do not see any install change. Also Microsoft Edge reports a change on 9 Apr 2021.

No recent events in the Setup Log.

Did a repair of Visual C++ 2013, shutdown and restarted.

A day later (11 Apr 2021) the same error is recorded and app has crashed. No change in installed apps.

April 12 2021-

Clean Win 10 install and latest updates. Tried to install latest version but needed earlier. Tried 6.0.3 which was most recent that was not an upgrade but it wants Visual C++ 2008. Stopped install. Copied entire folder from system before wipe and installed update assuming whatever upgrade needed would be there. That allowed install. Only Visual C++ 2013 is installed.

Will leave running for a few days before installing APC PowerChute Personal.

13
  • Latest news I see about Weather Link is from 2018. So you may need to check if it is compliant for the newest version of Windows 10
    – John
    Apr 5, 2021 at 14:58
  • "The system has Visual C++ 2008,2013 and 2015" - The only version the application requires is the Visual C++ 2013 Redistributable. My suggestion is to uninstall all versions and only install the required version. "App reports unable to write." - Please provide an adequate information required to diagnose your problem.
    – Ramhound
    Apr 5, 2021 at 15:01
  • @Ramhound Will grab the write error message next time it happens.
    – Dave M
    Apr 5, 2021 at 15:28
  • @John The vendor reports it is compliant
    – Dave M
    Apr 5, 2021 at 15:29
  • You said you reinstalled Windows and did all the updates, so I am not sure why this error would occur. I will look around a bit.
    – John
    Apr 5, 2021 at 16:27

1 Answer 1

0

The Microsoft Error Lookup Tool might be used to check the description of this error: 0xc0000409. After loading the tool run the following command:

Err_6.4.5.exe c0000409

It say:

# for hex 0xc0000409 / decimal -1073740791
  STATUS_STACK_BUFFER_OVERRUN                                    ntstatus.h
# The system detected an overrun of a stack-based buffer in
# this application. This overrun could potentially allow a
# malicious user to gain control of this application.
# 1 matches found for "c0000409"

Considering that you tested this application for required version of the Visual C++ Redistributable package, including uninstalling versions not required by this application (Visual C++ 2008 and 2015), I would guess that this is a bug in the WeatherLink program.

For example, to be more precise, an application can use APIs that worked correctly in Windows 7/8, but in the Windows 10 environment, with certain parameters, will cause overrun of a stack-based buffer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.