9

I wanted to test something in Diagnostic startup mode. For some reason upon reboot, my PC showed my account picture with an error saying "Something happened and you PIN isn't available. Click to set up you PIN again." When I click on Set up my PIN, there is a pause, then I get the same message again. When I click on it again, I often get a dialog window saying "Search for app in the store" but if I choose yes, nothing happens.

I've Googled and found this thread with no answer.

I've rebooted into Safe Mode using the Recovery Reboot Screen with no luck.

2 Answers 2

18

OK To fix this specific issue, I had to do the following:

  1. Hold Shift and click the power icon, choose "Restart" and wait until you see the blue Windows recovery screen.
  2. Choose "Advanced" and choose Command Prompt
  3. You'll restart and you should be put to a screen where it asks you for your MS Password. Input that and you should get a Command Prompt.
  4. Input the following commands:
  5. move c:\windows\system32\utilman.exe c:\
  6. copy c:\windows\system32\cmd.exe c:\windows\system32\utilman.exe
  7. Restart your computer.
  8. On the login screen, now click the "Ease of Use" icon at the bottom-right next to the Power button.
  9. A command prompt will open.
  10. Type "msconfig"
  11. Change the "Startup Selection" to "Normal Startup"
  12. Restart the computer.

From there you should be able to log in with your PIN as usual. The last step is to clean-up what you did and re-enable accessibility:

  1. Open a folder explorer and go to C:\
  2. Copy the "Utilman.exe" file from there into the C:\Windows\System32\ folder
  3. It'll ask for administrator privileges, Continue, and you should be back to normal.
12
  • 1
    This is the only solution that worked for me! thank you! Sep 21, 2022 at 10:57
  • Thanks. To restore, I used cmd with admin privileges to copy the original file back to system32. The Explorer method was giving me errors.
    – OXiGEN
    Oct 16, 2022 at 16:06
  • 1
    Works like a charm! Just remember that while you are moving/copying files in Recovery Mode your Windows installation may be accessible under different drive letter than C. In my case it was D. Nov 11, 2022 at 18:37
  • 2
    You are legit a life saver brother! Dec 8, 2022 at 20:15
  • 1
    I, too, fell prey to Microsoft's sloppy engineering today, and I can confirm that this approach still works on 22H2. You just have to use the option to boot without early anti-malware protection because Windows Defender (?) deletes Utilman.exe if it doesn't match some expected signature. I'm genuinely baffled by Windows 10 having several configuration options that quite literally brick the computer, and the only feasible fix requires you to use this ancient hack. Seriously, WTF, Microsoft?!
    – natiiix
    Sep 1, 2023 at 1:24
5

I didn't try the other answer because it seemed super risky to move .exe files in System32 around, but I found another solution that only involves disabling the "pin-only" sign-on via RegEdit in Windows Recovery mode. This is I think a much less risky solution (and worked for me). Full credit to ramava on LTT for figuring this out. I'm pasting that answer below verbatim in case the link above breaks eventually:

This happened to me last night and I want to document it here so that hopefully someone else won't have to spend 3 hours trying to fix it through trial and error, or worse, have to "Reset my PC" or reinstall, which I was very close to doing before I solved it. Then later, I recreated the problem on a virtual machine of a fresh Windows 10 install to see which thing I did actually fixed it and discovered another potential problem that people may encounter. This may not solve the problem completely if it was originally caused by something different than my problem, but hopefully it'll be a good head start for those people.

The Problem:

The problem is caused by a sign-in setting for Microsoft accounts in later builds of Windows 10 that prevents you from using a regular password to logon, but doesn't work at all if the services that make Windows Hello work aren't running. This setting is enabled by default.

THDrKnU.png

For me, this happened because I enabled Diagnostic Startup in msconfig. This disabled all the required services and then I couldn't logon because the only account on the computer was made using a Microsoft Account instead of a local account.

WHMh7BC.png

After pressing ok and rebooting, I was presented with this:

aMPvaEF.png

The Solution:

First, hold down Shift while pressing restart on the logon screen. This will bring up the Recovery options on reboot.

dQSdeY0.png

Click Troubleshoot -> Advanced Options -> Command Prompt.

lKYGaGd.png

elpIgMC.png

GSIZlpv.png

You may be asked to log in at this point, which I think depends on your which build of Windows it is. It did use the password and didn't seem to have any trouble on the one machine that required me to do it. The much newer preview build never asked for one.

Run regedit.

kX4aEFC.png

This will bring up the registry for the recovery environment (WinRE), not your install of Windows. So you have to manually load the registry hive to be able to edit them. To do that, first select HKEY_LOCAL_MACHINE, then select File -> Load Hive... from the menu.

VnQdFst.png

The hive files will be in C:\Windows\System32\config (or in the case of one of my computers, it was E:). Load the SOFTWARE hive file. It will ask you for a name. I normally just use an extra s in front of the name, but it really doesn't matter as long as it's not something that's already there. This will give us a new listing under HKLM. My instructions will assume you name them ssoftware and ssystem like I do.

(Note: Don't use the version on the X:\ drive. It's the registry from the stripped down version of Windows that you're currently using to fix this.)

TKt0Wlt.png

ZpUpy7C.png

Solution #1:

Go to HKEY_LOCAL_MACHINE\ssoftware\Microsoft\Windows NT\CurrentVersion\PasswordLess\Device. There there is a key for DevicePasswordLessBuildVersion. Change the value from 2 to 0. This will turn off that "Require Windows Hello" setting.

Now reboot. If you're lucky, you can now logon with your password, and then hopefully fix whatever is causing the issue. In my case, it was just going back to Normal Startup in msconfig.

If it tells you that your password is incorrect (even though it's the right password), that means the password has never actually been used before and we have to do some extra steps.

Solution #2:

To make this work, we need to enable some logon services for Microsoft Accounts and make sure network access is enabled by enabling services.

Reboot back to the WinRE command prompt and open regedit again. This time, we'll load the SYSTEM hive as ssystem.

Under HKEY_LOCAL_MACHINE\ssystem\ControlSet001\Services, we're going to go to each service and edit the Start key value. For reference, the valid values for startup type here are:

0: Boot
1: System
2: Automatic
3: Manual
4: Disabled

cTYiPKF.png

The short name is where you'll find it in the registry, in parenthesis is the long name for it. Some of these may seem unnecessary, but they are dependencies for other services.

These services need to be set to Manual startup (Start = 3):

lmhosts                (TCP/IP NetBIOS Helper)
Netman                (Network Connections)
VaultSvc            (Credential Manager)
Wecsvc                (Windows Event Collector)
WbioSrvc            (Windows Biometric Serviced)
wlidsvc                (Microsoft Account Sign-in Assistant)

And these services need to be set to Automatic startup (Start = 2):

Dhcp                    (DHCP Client)
EventLog                (Windows Event Log)
EventSystem            (COM+ Event System)
LanmanServer            (Server)
LanmanWorkstation        (Workstation)
NlaSvc                (Network Location Awareness)
nsi                    (Network Store Interface Service)
SamSs                    (Security Accounts Manager)

Reboot. Hopefully, Windows will now be able to contact Microsoft's servers and validate your password so you can logon.

2
  • 1
    I'd argue it is much riskier to mess with regedit. The accepted answer safely swaps executables (keeping a backup of the original) and safely swaps them back. The reason is to have the available button (accessibility) trigger the executable we need access to (cmd.exe) to run the tools we need (msconfig) to get out of the mess in the same way we got into it. Of course, all this wouldn't be necessary if MS just offered a "Restart Normally" option in the power menu.
    – OXiGEN
    Oct 16, 2022 at 16:11
  • IMO, your answer is useful in isolating the Windows hello option as the culprit, but is indeed much riskier than the simple copy of Utilman suggested in the accepted answer. Manually loading and mucking with a registry is beyond terrifying.
    – luv2learn
    Jun 9, 2023 at 11:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .