66

I'd like to prevent the Mac Terminal program from beeping, for example when there are multiple possible completions when I hit TAB. I looked in the preferences, but there's nothing about beeping.

9 Answers 9

90

In OS X Leopard (10.5 and later)

  1. Open Terminal.
  2. On the menu go to Terminal > Preferences.
  3. Open Settings > Advanced ("Profiles" tab for Big Sur)
  4. Un-check the "Audible Bell" option. (You can also set "visible bell" which will cause your terminal to flash instead of beep)

In OS X Tiger (10.4 and earlier):

  1. Open Terminal.
  2. On the menu go to Terminal > Window Settings.
  3. In the Terminal Inspector window click on the drop-down list and select Emulation.
  4. Un-check the "Audible Bell" option. (You can also set "visible bell" which will cause your terminal to flash instead of beep)
3
  • Is that for Tiger? There's no Window Settings option in Leopard...
    – Jon
    Dec 30, 2008 at 8:56
  • @Jon: Yes, that does not appear to be on Leopard.
    – ayaz
    Dec 30, 2008 at 9:34
  • 4
    Under Leopard, the same settings are avaliable under Terminal > Preferences, under the Settings > Advanced tabs.
    – Chris Lutz
    Sep 24, 2009 at 2:34
14

I'm presuming you have Leopard, whose terminal is greatly improved over Tiger's.

Terminal menu --> Preferences --> Settings tab --> Advanced --> Bell.

Untick "Audible bell"

(btw, mine doesn't beep as far as I can tell, even though that setting is enabled for me)

2
  • 1
    It should play the standard sound warning, configurable in system preferences -> sound -> sound effects tab
    – Agos
    Jan 31, 2010 at 1:00
  • On my 2019 MacBook the sequence is Terminal preferences --> Profiles --> Silver Aerogel -> Advanced --> uncheck Audible bell.
    – Noumenon
    Feb 12, 2021 at 1:12
7

put "set bell-style visible" in your ~/.bashrc

3
  • 1
    That only affects Bash, not everything. Jan 5, 2010 at 14:28
  • 1
    @ThorbjørnRavnAndersen, it’s probably better to configure specific programs to not beep for specific events, rather than disabling the terminal bell altogether, since it’s usually used for things that may need the user’s attention. Going the other direction, if all beeps in the terminal are annoying, there’s a good chance the user will also find beeps annoying in other applications, in which case they should consider muting “sound effects” system-wide in System Preferences > Sound.
    – Chris Page
    Jan 5, 2012 at 21:07
  • See also inputrc, show-all-if-ambiguous and show-all-if-unmodified in the Bash man page, to specifically avoid beeping during autocompletion. x-man-page://1/bash
    – Chris Page
    Jun 15, 2012 at 0:00
4

The process is a bit different in El Capitan.

OS X El Capitan (10.11)

  1. Open Terminal.
  2. On the menu go to Terminal > Preferences.
  3. Choose the Profile tab
  4. Choose the profile from the left panel.
  5. Un-check the Audible Bell option.

Steps after opening the preferences

1
  • 3
    And the bell options are now in Advanced tab under each individual profiles.
    – zyy
    May 5, 2020 at 16:39
1

On Big Sur (10.1)

  1. open terminal app
  2. On the menu go to Terminal > Preferences.
  3. select Profiles (your profile should be highlighted)
  4. select Advanced tab on far right
  5. uncheck bell under Bell
0

System preferences --> sound --> then choose an alert sound [choose what you want]

then quit and reopen the terminal.

0

Use ITERM2 and RX click to change all the settings (you might enable visual bel, to see when you make some mistakes without being bothered by sounds)

0

To do it via terminal:

TERMINAL_PLIST="$HOME/Library/Preferences/com.apple.Terminal.plist"
TERMINAL_THEME=`/usr/libexec/PlistBuddy -c "Print 'Default Window Settings'" $TERMINAL_PLIST`
/usr/libexec/PlistBuddy -c "Set 'Window Settings':$TERMINAL_THEME:Bell false" $TERMINAL_PLIST
/usr/libexec/PlistBuddy -c "Set 'Window Settings':$TERMINAL_THEME:VisualBellOnlyWhenMuted false" $TERMINAL_PLIST
0

If using Kitty as the terminal app, see terminal bell

i.e.

open ~/.config/kitty/kitty.conf and uncomment/set the following lines:

enable_audio_bell no

#optional, flashes screen.
visual_bell_duration 0.5

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .