0

I would be most grateful for any pointers which lead to resolving the following issue.

The Problem
When I use windows search (win + s) the icons for windows 10 related apps are shown with a photoshop icon which appears to be layered over the top.

The icons are shown incorrectly on both the search pane as well as in the actual list of search results. It appears that it is only affecting Microsoft Store Apps from Microsoft such as calculator, calendar and the Microsoft Store app itself.

The correct icons are shown for all other apps including Word, Excel etc; they are all shown in search with the correct Icon, including some from the Microsoft Store.

The icons for applications that are affected by my issue are shown correctly everywhere else in the system just not within the search.

What I have tried.

  • Change display scaling.
  • Cleared the icon cache.
  • Cleared temp folder.
  • Reset the Microsoft Store App
  • Uninstalled one of the problem apps (calculator) and re-installed.

There was mention in a forum that BitDefender may be causing the issue but there were no specifics.

The screenshot below shows the issue if you look carefully it appears like the Photoshop Icon is somehow layered on top with the correct icons being slightly visible. Also, the command prompt Icon is shown correctly.

Edit: Also ran the following commands.

  • DISM.exe /Online /Cleanup-image /StartComponentCleanup
  • DISM.exe /Online /Cleanup-Image /Restorehealth
  • SFC /SCANNOW Rebooted afterwards

enter image description here

4
  • 1
    Try DISM / SFC (1) Open cmd.exe with Run as Administrator. (2) DISM.exe /Online /Cleanup-image /StartComponentCleanup (3) DISM.exe /Online /Cleanup-Image /Restorehealth (4) SFC /SCANNOW (5) Restart when all the above is complete and test
    – John
    Apr 10 at 0:50
  • Thanks for the tip, I ran those commands and while SFC did detect and fix one corrupt file it did not address the icon issue I am experiencing. Any other ideas?
    – M.Scherzer
    Apr 10 at 1:56
  • 1
    If DISM has not worked, try a Windows 10 Repair Install from the Media Creation link. microsoft.com/en-us/software-download/windows10 Use the 2nd link in the website and run in place. Keep Everything.
    – John
    Apr 10 at 1:59
  • I have done some more investigating and the same issue has been "synced" to my laptop so it must be a profile setting. It appears that all Microsoft Store provided Apps have this problem. Digging deeper I can see that the affected applications use PNGs as icons. Also, on my laptop the "overlay icon" is the one from the Photos App while on My Main Machine its photoshop. It would seem that the "search" wants to create a preview of the icon but instead just shows the Icon of the Default Image App. The question is: "Why is this happening, How to change It?
    – M.Scherzer
    Apr 10 at 3:21
1

I finally resolved the issue with some more understanding that the issue was only impacting apps from the Microsoft Store.

Unfortunately, I can't say "what actually fixed" the problem.

Somewhat, strange. I had just resigned myself to not being able to fix this when suddenly and unexpectedly the icons came back correctly on my Tower as well as on my Laptop.

So there was a significant delay between whatever resolved the issue and the resolution taking effect. However, I did follow the following two suggested avenues for a resolution and one of those worked.

If I had to pick likely candidates It would be "repeatedly" switching the "scaling" option I did this 4 times back to back I suspect that must trigger something in the search cache as that was the very last thing I did before the Icons returned to normal (with a delay of around 2 minutes).

The other possibility of the fix may have been from this answer by iSaumya

Some Windows 10 UWP icons not displaying on search, or in settings

I also followed these instructions:

https://answers.microsoft.com/en-us/windows/forum/all/windows-store-apps-icons-not-showing-in-search-bar/3a7ff815-a23b-4596-b308-eb558c298812

For the sake of completeness, I also want to mention that I had this issue on two computers that were synced and so I was troubleshooting at home and work.

I followed the Microsoft answer on my Laptop and the StackExchange at home. Possibly one of those solutions worked and then was synced across which then fixed the other computer.

I also uninstalled google drive during this process. Hopefully, that is enough information to help someone else out.

Good Luck!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.