0

I have a PC with an AMD Ryzen 3400G APU with Linux. I regularly experience a graphics phenomenon which has long affected users of similar Ryzen APU systems§:

  1. I am watching YouTube or playing a game using the integrated graphics.
  2. The screen freezes.
  3. A few seconds later, the screen blanks to black.
  4. No more than a second later, the screen returns to the frozen image from (2). The mouse pointer is visible and sometimes movable, but neither clicking on anything nor keyboard commands have any affect on the screen. Audio continues playing, so it's definitely a graphics problem.
  5. Sometimes restart from step (2), sometimes not.
  6. In the kernel SysLog, an error message similar to the follow is displayed:
[drm:amdgpu_dm_commit_planes.constprop.0 [amdgpu]] *ERROR* Waiting for fences timed out!   
[drm:amdgpu_job_timedout [amdgpu]] *ERROR* ring gfx timeout, signaled seq=92956, emitted seq=92958    

This problem could be caused by one of several bugs in any part of the Linux graphics system, so I don't know which of dozens of possible fixes are most suitable, or where to bug report it. For example, the kernel message is provided by amdgpu and the phenomenon only affects AMD Ryzen APUs (and possibly some AMD graphics cards of similar generations). So you might think that it should be reported to AMD's Linux driver team. But the AMD team either ignore such reports or redirect them to MESA without explanation. And I am reluctant to implement some of the fixes/workarounds that are liable to break my PC and void my warranty, such as changing the CPU voltages, if its a unrelated bug. I have tried several different BIOS and kernel parameters that have worked for others (SysLogs are available here), but none of them work for me.

But last week I had a weird twist to the behaviour:

  1. I was recently started playing the game CK3, viewing the map.
  2. The screen froze.
  3. The screen blanked to black.
  4. The screen displayed the CK3 loading screen! Not the map I was previously viewing, but something I had seen maybe five minutes earlier.

It was as though the PC had picked out a memory from earlier. I don't think CK3 had restarted, because I can't find any single click or keyboard command that could do that.

What part of the Linux graphics system could have brought back an earlier image?

The kernel? Mesa? The iGPU? This bug has been extensively reported,§ but it's still not even clear which team is responsible. I hope this weird symptom might help pin down which area of the graphics architecture is at fault.

Summary of the system (full details available here):

  • CK3 uses OpenGL, I think
  • KDE Plasma 5.18.5
  • Ubuntu 20.4.2 LTS
  • Mesa 20.2.6
  • Linux kernel 5.8.0
  • AMD Ryzen 5 3400G with Vega 11
  • MSI Mortar Max B450M motherboard

§ I have found related bug reports at the kernel, AMDGPU, Mesa, Ubuntu, other distributions and several AskUbuntu questions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.